Bug 52059 - kcmlinuz doesn't work with 2.5.x kernels
Summary: kcmlinuz doesn't work with 2.5.x kernels
Status: RESOLVED NOT A BUG
Alias: None
Product: kcontrol
Classification: Miscellaneous
Component: kcmlinuz (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 80 votes (vote)
Target Milestone: ---
Assignee: Malte Starostik
URL:
Keywords:
: 54271 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-12-18 12:24 UTC by Malcolm Scott
Modified: 2005-02-23 03:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Malcolm Scott 2002-12-18 12:24:59 UTC
Version:            (using KDE KDE 3.0.99)
Installed from:    Gentoo Packages
Compiler:          gcc (GCC) 3.2.1 20021207 (Gentoo Linux 3.2.1-20021207) 
OS:          Linux

When I try to use the Linux Kernel Configurator in the KDE Control Panel, configuring kernel 2.5.52, I get the following error message:

    cannot open /usr/src/linux-beta//arch/i386/config.in for reading

This is because there are no config.in files in this kernel tree - perhaps the kernel config file layout has changed? It would be useful for the control module to work with the development kernels, and indeed with the future 2.6 series.

(I don't know whether this is relevant, but I'm actually running kernel 2.4.19 at the moment, but trying to configure 2.5.52.)
Comment 1 George Staikos 2003-02-12 01:22:49 UTC
Yes we haven't added support for the new kernel configuration system yet. 
Comment 2 George Staikos 2003-02-15 21:30:37 UTC
*** Bug 54271 has been marked as a duplicate of this bug. ***
Comment 3 Ismail Donmez 2003-04-21 13:44:42 UTC
2.5 kernel uses QT interface when you choose make xconfig.
Maybe that helps you until this bug is fixed.
Comment 4 ccheney 2003-05-23 10:05:30 UTC
This bug appears to be in the new 2.4 kernels as well. I tested kcmlinuz from 
KDE 3.1.2 against 2.4.21-rc2-ac2 and it said: 
 
The kernel configuration could not be read due to the following error:  
 
cannot open /usr/src/kernel-source-2.4.21-rc2-ac2//arch//config.in for reading 
 
Either your kernel sources contain invalid configuration rules or you just 
found a bug in the KDE Kernel Configurator. 
 
It also wouldn't show anything in the arch drop down box. 
Comment 5 Paulo Fidalgo 2003-09-21 15:59:18 UTC
Here goes my suggest:
Add support for the newer kernels like 2.6.x, and add support for applying 
patchs to kernel. 
Comment 6 Felix De Vliegher 2003-11-22 21:29:00 UTC
Yeah it would like to see this working too.
Would be nice to be able to configure my 2.6 kernel in kcontrol
Comment 7 Per (phobie) 2004-05-13 02:29:11 UTC
Yes, I think about 20% use 2.6.x kernels.
Since 2.6.2 it runs on my machine.
Comment 8 Robert Richter 2004-10-14 10:52:05 UTC
Kernel 2.6 is standard in many new Distributions 
(like: SuSE LINUX 9.1/9.2;Debian 3.1 sarge ...).
Now it's time for it!
Comment 9 Thibaut Cousin 2004-11-14 10:30:40 UTC
Kernel 2.6 has been out for quite some time now. Seeing kcmlinuz say that it doesn't support kernel 2.5 or higher is a bit strange. If nobody can update it to support current kernels, maybe you should consider removing that module?
Comment 10 Gilles Schintgen 2005-01-28 16:37:54 UTC
I couldn't agree more with the previous comment: fix it or drop it.
This is not meant as an offense, it's just that kcmlinuz is totally outdated and reflects badly on the excellent overall quality of the control center.
Comment 11 Jo Øiongen 2005-02-08 21:38:51 UTC
Should this bug then be closed as "INVALID"? Please see http://lists.kde.org/?l=kde-core-devel&m=110727153114866&w=2

Cheers Jo
Comment 12 Per (phobie) 2005-02-10 14:41:42 UTC
"INVALID"?
Why that?
The bug is valid and releasecritical.
kcmlinuz should be removed from stable sources and remain in beta until someone fixes this bug.
Comment 13 Maksim Orlovich 2005-02-10 16:27:17 UTC
Uhm, follow the link. It's exactly because it -was- removed from release sources. And no, this is not release critical at all.
Comment 14 Daniel Molkentin 2005-02-23 03:50:53 UTC
Closed because of removal from source package.