Bug 51227 - When two balls are together the game blocks
Summary: When two balls are together the game blocks
Status: RESOLVED FIXED
Alias: None
Product: kolf
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jason Katz-Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-11-26 21:07 UTC by Tamara nocambie
Modified: 2010-11-01 00:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tamara nocambie 2002-11-26 21:07:47 UTC
Version:           1.1 (using KDE 3.0.9)
Compiler:          gcc version 2.95.4 20011002 (Debian prerelease)
OS:          Linux (i586) release 2.4.17

When two balls get too near, it looks like the phisic algorithm never finishes, and it's imposible to play further, but you can access the menu and right-click to see field info, so the program is not blocked.
Comment 1 phrensy 2003-02-16 21:08:52 UTC
I've encountered this bug as well.  I got the impression the balls bump into each 
other, and bounce back and forth forever, but neither ball moves far enough to 
separate the two. 
 
I am using Kolf 1.1 on KDE 3.1.0.  I compiled using Konstruct (although I recompiled 
kdelibs with --enable-debug). 
 
 
Comment 2 Rob Kaper 2003-10-07 01:19:40 UTC
I can confirm this, just happen to me on hole 6 of USA Pro. 
Comment 3 Jason Katz-Brown 2003-12-17 09:05:05 UTC
Sorry I'm just not sure how to fix this, and it's bloody hard to reproduce :-/	
Comment 4 George Goldberg 2007-12-19 03:48:24 UTC
Is this bug still there in a recent version of KDE, such as 3.5.8 or KDE4.0 RC2?
Comment 5 Stefan Majewsky 2010-11-01 00:23:10 UTC
SVN commit 1191723 by majewsky:

Make Box2D the default physics engine for Kolf.

Mission accomplished, folks!

CCMAIL: kde-games-devel@kde.org
BUG: 46532
BUG: 51227
BUG: 131488

 M  +0 -10     ball.cpp  
 M  +1 -5      ball.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1191723