Bug 51048 - Many icons missing in Crystal
Summary: Many icons missing in Crystal
Status: RESOLVED DUPLICATE of bug 78261
Alias: None
Product: artwork
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 91 votes (vote)
Target Milestone: ---
Assignee: Frans Englich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-11-22 16:26 UTC by Rob Kaper
Modified: 2005-06-30 23:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Kaper 2002-11-22 16:26:43 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

Many icons are missing from Crystal. It looks like almost all of the non-base icons (libkdegames is a good example, but so are most application icons) do not have Crystal versions.

While the fallback to hicolor works splendidly, almost every menu or toolbar I have seems to need the fallback and Crystal and hicolor simply don't mix and match, causing for a horribly inconsistant user interface in almost any app but Konqueror.
Comment 1 David Faure 2002-11-22 16:32:32 UTC
Subject: Re:  New: Many icons missing in Crystal

>            Product: kdesktop

Hi Rob. You know what kdesktop is?
Please reassign to artwork.

Comment 2 Rob Kaper 2002-11-22 16:44:16 UTC
Subject: Re:  Many icons missing in Crystal

On Fri, Nov 22, 2002 at 03:32:33PM -0000, David Faure wrote:
> Hi Rob. You know what kdesktop is?
> Please reassign to artwork.

Ah, the wizard screwed me here, will do.

Rob
Comment 3 Rob Kaper 2003-07-21 17:01:01 UTC
Subject: Re: kdemultimedia/noatun/modules/systray

On Sun, Jul 20, 2003 at 12:26:00PM -0700, Neil Stevens wrote:
> On Sunday July 20, 2003 10:38, Stefan Gehn wrote:
> > Maybe we should ask Everaldo and friends to give us some decent
> > media-player action icons so we can get rid of the blakc blocks you
> > mentioned (btw, these get used in our GUI too, even there they look
> > ugly)
> 
> Have you ever gotten one response from them regarding your icon needs?

Not on kde-core-devel, the bug entry (#51048, assigned to David though, hm)
*or* kde-cvs. I'll be a bitch and will cc: them all.

Crystal team: a lot of application developers are still waiting for
consistant cr* icons for their applications. Personally I expected that the
renamed/copied icons from hi* were just going to be placeholders, but it's
starting to look like this inconsistancy will be permanent. It's dramatic
that an icon theme from kdeaddons (Noia) features a more complete set than
Crystal.

At the moment I consider Crystal to be equally unmaintained as hicolor. That
worries me.

Rob
Comment 4 Rob Kaper 2003-10-16 17:14:41 UTC
Subject: Re: kdelibs/pics/crystalsvg

On Thu, Oct 16, 2003 at 05:00:06PM +0200, George Staikos wrote:
> me2!!

I made a script which checks for all Crystal icons and sees if they're the
same as kdeclassic or not. It won't find kdeclassic icons missing in
Crystal, but it will report all those pesky ones that were simply copied and
never updated.

Requires kdeartwork/IconThemes/kdeclassic to be checked out, as well as
whatever module you want to check of course.

Sample result for kdenetwork: 22 icons are new or were updates, 64 are still
the same.

cap@kira:~/src/kde-cvs$ ./findmissingcrystal kdenetwork | grep OK | wc -l
     22
cap@kira:~/src/kde-cvs$ ./findmissingcrystal kdenetwork | grep ERR | wc -l
     64

Script is in kdesdk/scripts.

Sample output:

OK /diff: kdenetwork/kmail/cr48-app-kmail.png
OK /new : kdenetwork/kmail/cr64-app-kmail.png
ERR/same: kdenetwork/kmailcvt/cr16-app-kmailcvt.png

(three results possible: the icon is different, the icon is new.. or it;''s
the plain old hicolor one)

Rob
Comment 5 Chelsea Buchanan & Keith Briscoe 2004-02-05 06:29:57 UTC
Just switched from Classic to Crystal when I upgraded to KDE 3.2, and I'm noticing this too.  In particular, there is no "FTP URL" icon.  Just one more for the list...
Comment 6 Helge Hielscher 2004-05-09 21:06:14 UTC
The sources of the crystal icons can also be found at http://www.kde-look.org/content/show.php?content=11862
Comment 7 Troy Phillips 2004-12-14 05:20:18 UTC
(As noted in bug 78261) the crystal icons in kdebase-3.3.1-4.1 are based on an old beta version of Crystal SVG. I downloaded "Crystal SVG 1.0" icon set from http://linuxcult.com/forum/crystal/Crystal_SVG.tar.gz (i.e official download from Everaldo.com) and it had lots of extras and quite a few updated icons. 

The extra icon that I personally required was vmware.png, but it has alot of extras too.
Comment 8 Troy Phillips 2005-03-15 05:27:11 UTC
Is anyone maintaining the "artwork" product? There are only two bugs in the product (both about updating the Crystal icons), but they have both been around for years :(
Comment 9 Heinrich Wendel 2005-06-30 22:58:43 UTC

*** This bug has been marked as a duplicate of 78261 ***
Comment 10 Rob Kaper 2005-06-30 23:12:21 UTC
Without trying to be pedantic (okay, maybe after all) it is custom practise to keep the oldest bug entry as original and mark newer ones as duplicate, not the other way around.