Bug 48927 - let <message> search all decoded body parts
Summary: let <message> search all decoded body parts
Status: RESOLVED WAITINGFORINFO
Alias: None
Product: kmail
Classification: Applications
Component: filtering (show other bugs)
Version: 1.4.7
Platform: Gentoo Packages Linux
: NOR wishlist with 5 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 67156 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-10-09 16:25 UTC by sean
Modified: 2012-08-19 01:08 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Contains ".vbs" in 3rd attachment (145.76 KB, text/plain)
2002-10-09 16:27 UTC, sean
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sean 2002-10-09 16:25:19 UTC
Version:           1.4.7 (using KDE 3.0.8 (KDE 3.1 beta2))
Installed from:    Gentoo
Compiler:          gcc version 3.2
OS:          Linux (i686) release 2.4.19-xfs-r1

I found what I believe is inconsistent behavior. When viewing mail, a base64 encoded html attachment is rendered below the message body (first of the multiparts is a quoted-printable block which is rendered first). Incidentally, this breaks rendering because there are two <html>..</html> blocks, the second block is displayed as unparsed text. But that's not the bug I'm reporting. 

When a filter is created to act on text contained in this "message body" the filter fails, because I presume that the filter is applied only to the undecoded text? I think that, because I am presented with decoded text in the message body window that I should be able to filter on this text too.

I'll attach the specific message that caused this problem. It looks like a klez email, so in response I wanted to add a filter to move any message containing ".vbs"  to my dumpster folder. The ".vbs" in this message is located in the third decoded attachment, but kmail isn't finding it.
Comment 1 sean 2002-10-09 16:27:51 UTC
Created attachment 172 [details]
Contains ".vbs" in 3rd attachment
Comment 2 Stephan Kulow 2003-09-27 10:43:53 UTC
that's a missing feature 
Comment 3 Ingo Klöcker 2005-06-06 00:50:09 UTC
*** Bug 67156 has been marked as a duplicate of this bug. ***
Comment 4 Patrick Carabin 2007-07-18 17:55:53 UTC
I've been looking regularly for messages containing a string, and could NOT find them because of this <<bug>>... Please help by changing this behaviour : check the WHOLE message, not only a part of it. Thanks.
Comment 5 Myriam Schweingruber 2012-08-18 08:45:18 UTC
Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.
Comment 6 Luigi Toscano 2012-08-19 01:08:22 UTC
Instead of creating a new feature request, please confirm here if the wishlist is still valid for kmail2.