Bug 48406 - selections coming from x2x don't work
Summary: selections coming from x2x don't work
Status: RESOLVED INTENTIONAL
Alias: None
Product: kdelibs
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-09-28 11:46 UTC by Riku Voipio
Modified: 2002-10-20 19:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riku Voipio 2002-09-28 11:46:43 UTC
Version:            (using KDE KDE 3.0.3)
Installed from:    Debian testing/unstable Packages
OS:          Linux

x2x is a piece of software that links two X displays together,
allowing to use the keyboard/mouse from one display to control another X display.

Steps to reproduce:

1. x2x -to $REMOTEHOST:0 -west
2. select something locally
3. move the mouse to the "other" display by moving the mouse to the left edge
4. pasting the selection with midlle button on any kde app (konsole/konqeror tested)
*nothing happens*
5. pasting to any other application (xterm/mozilla tested)
*text get's pasted as expected

Since it works woth non-kde apps, i have to assume that it is a kdelibs, and not a x2x bug.
Comment 1 Stephan Kulow 2002-10-20 19:00:49 UTC
I'm not really an expert in that area, but x2x only forwards the   
X selection, not the clipboard.  
But if anything this is a Qt problem as you can reproduce this 
very problem with a pure Qt application.