Bug 45119 - kdf Signal 6 SIGABRT
Summary: kdf Signal 6 SIGABRT
Status: CLOSED FIXED
Alias: None
Product: kdf
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Other
: NOR crash (vote)
Target Milestone: ---
Assignee: Michael Kropfberger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-07-13 17:03 UTC by sspies
Modified: 2008-01-19 09:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sspies 2002-07-13 17:02:46 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           
Version:           KDE 3.0.0 
Severity:          crash
Installed from:    Debian stable Packages
Compiler:          
OS:                
OS/Compiler notes: 

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...0x40d19a39 in wait4 () from /lib/libc.so.6
#0  0x40d19a39 in wait4 () from /lib/libc.so.6
#1  0x40d90e48 in __check_rhosts_file () from /lib/libc.so.6
#2  0x4052d4d8 in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.3

#3  0x40ca26b8 in sigaction () from /lib/libc.so.6
#4  0x40ca3be1 in abort () from /lib/libc.so.6
#5  0x406e0fdb in qFatal () from /usr/lib/libqt.so.2
#6  0x0805d043 in virtual function thunk (delta:-36) for QWidget::metric ()
#7  0x404e1c2e in KProcess::processExited () from /usr/lib/libkdecore.so.3
#8  0x404e05de in KProcess::processHasExited () from /usr/lib/libkdecore.so.3
#9  0x404e2a5d in KProcessController::slotDoHousekeeping ()
   from /usr/lib/libkdecore.so.3
#10 0x407a745f in QObject::activate_signal () from /usr/lib/libqt.so.2
#11 0x40803578 in QSocketNotifier::activated () from /usr/lib/libqt.so.2
#12 0x407dfea2 in QSocketNotifier::event () from /usr/lib/libqt.so.2
#13 0x4074eef7 in QApplication::notify () from /usr/lib/libqt.so.2
#14 0x404861f4 in KApplication::notify () from /usr/lib/libkdecore.so.3
#15 0x4071691a in qt_set_socket_handler () from /usr/lib/libqt.so.2
#16 0x4071701e in QApplication::processNextEvent () from /usr/lib/libqt.so.2
#17 0x407513bf in QApplication::enter_loop () from /usr/lib/libqt.so.2
#18 0x4071df23 in QApplication::exec () from /usr/lib/libqt.so.2
#19 0x08054196 in QCollection::newItem ()
#20 0x40c9214f in __libc_start_main () from /lib/libc.so.6


(Submitted via bugs.kde.org)
(Called from KBugReport dialog. Fields KDE Version manually changed)
Comment 1 Maksim Orlovich 2002-08-07 02:27:53 UTC
Thank you for your bug report.
The bug that you reported has been identified and has been fixed in the
versions of KDE >=3.0.0. The bug report will be closed.
Comment 2 Francisco Baptista 2006-09-04 01:14:11 UTC
Dear,

I am on Ubuntu 6.06 LTS, Gnome 2.14.3.

I got the SIGABRT signal 6 Error mesage when I am using Quanta Plus version 3.5 specially when editing remote files (via FTP).

Any idea how can I fix that.

Regards

Francisco Baptista
francisco@tomboa.net
Comment 3 antonio 2007-03-14 18:34:23 UTC
Hello, the Kde Crash Handler has informed me about this crash in konqueror...i send this report, thank you
Antonio
Comment 4 keith mulligan 2007-04-04 02:29:54 UTC
I get this when I try to open my home folder, 
The application Konqueror crashed and caused the signal 6(SIGABRT)

An application terminates with a SIGABRT signal when it detects an internal inconsistency caused by a bug in the program.
Comment 5 Daniel 2007-06-03 23:48:23 UTC
I am on Kubuntu The Dapper Drake 6.06
I use Linux 2.6.15 and my desktop environment is KDE 3.5.2
I got this signal 6 SIGBRT bug while trying to open a chart with OpenOffice 2.0 Spreadsheet. The application crashed because of an internal inconsistency due to a bug or a program.

I don't know how to resolve this :/ this bug status is CLOSED, not RESOLVED
Comment 6 Bram Schoenmakers 2007-06-04 19:11:18 UTC
Antonio, Keith and Daniel, please open new bug reports regarding this issue and provide a backtrace.

Please read http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports for learning about creating good backtraces.
Comment 7 filippo costadoni 2008-01-06 02:34:19 UTC
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1227405632 (LWP 5496)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb798c875 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb798e201 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb79c3e5c in ?? () from /lib/tls/i686/cmov/libc.so.6
#10 0x0000000b in ?? ()
#11 0xbfedeb04 in ?? ()
#12 0x00000400 in ?? ()
#13 0xb7a8e0c8 in ?? () from /lib/tls/i686/cmov/libc.so.6
#14 0x00000017 in ?? ()
#15 0xbfee0962 in ?? ()
#16 0x00000014 in ?? ()
#17 0xb7a8e0e1 in ?? () from /lib/tls/i686/cmov/libc.so.6
#18 0x00000002 in ?? ()
#19 0xb7a8e13c in ?? () from /lib/tls/i686/cmov/libc.so.6
#20 0x00000023 in ?? ()
#21 0xb7a8e0e5 in ?? () from /lib/tls/i686/cmov/libc.so.6
#22 0x00000004 in ?? ()
#23 0xbfedf07b in ?? ()
#24 0x00000008 in ?? ()
#25 0xb7a8e0eb in ?? () from /lib/tls/i686/cmov/libc.so.6
#26 0x00000005 in ?? ()
#27 0x0807bdf0 in ?? ()
#28 0xb7961a2c in ?? () from /usr/lib/libXrender.so.1
#29 0x0807bdf0 in ?? ()
#30 0x08073bd0 in ?? ()
#31 0xbfedea68 in ?? ()
#32 0xb78a4250 in _XAllocID () from /usr/lib/libX11.so.6
#33 0xb79cbd65 in ?? () from /lib/tls/i686/cmov/libc.so.6
#34 0x00000002 in ?? ()
#35 0xb7a8e0c8 in ?? () from /lib/tls/i686/cmov/libc.so.6
#36 0xbfee0962 in ?? ()
#37 0xb7a8e13c in ?? () from /lib/tls/i686/cmov/libc.so.6
#38 0xbfedf07b in ?? ()
#39 0x08074198 in ?? ()
#40 0xbfedf07b in ?? ()
#41 0x08140f88 in ?? ()
#42 0xb7aa9148 in ?? () from /lib/tls/i686/cmov/libc.so.6
#43 0x08073bd0 in ?? ()
#44 0xb7a8e13c in ?? () from /lib/tls/i686/cmov/libc.so.6
#45 0xb78a66c4 in _XReply () from /usr/lib/libX11.so.6
#46 0xb79cf800 in free () from /lib/tls/i686/cmov/libc.so.6
#47 0xb78a3d6d in XFree () from /usr/lib/libX11.so.6
#48 0xb6b28118 in CrystalClient::ClientWindows ()
   from /usr/lib/kde3/kwin3_crystal.so
#49 0xb6b28574 in CrystalClient::mouseWheelEvent ()
   from /usr/lib/kde3/kwin3_crystal.so
#50 0xb6b2cdcd in CrystalClient::eventFilter ()
   from /usr/lib/kde3/kwin3_crystal.so
#51 0xb734ae40 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#52 0xb734aebe in QObject::event () from /usr/lib/libqt-mt.so.3
#53 0xb73825b3 in QWidget::event () from /usr/lib/libqt-mt.so.3
#54 0xb72e2af0 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#55 0xb72e4f4a in QApplication::notify () from /usr/lib/libqt-mt.so.3
#56 0xb7dbaca2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#57 0xb727527d in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#58 0xb726651b in QETWidget::translateWheelEvent ()
   from /usr/lib/libqt-mt.so.3
#59 0xb7273522 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#60 0xb7271fcc in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#61 0x08055e0f in ?? ()
#62 0xb7261153 in ?? () from /usr/lib/libqt-mt.so.3
#63 0x0806d0f8 in ?? ()
#64 0xbfedfe38 in ?? ()
#65 0x00000004 in ?? ()
#66 0xb78138d0 in ?? () from /usr/lib/libqt-mt.so.3
#67 0xbfedfe38 in ?? ()
#68 0xb78138d0 in ?? () from /usr/lib/libqt-mt.so.3
#69 0xbfedfcd8 in ?? ()
#70 0xb72718e2 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
Backtrace stopped: frame did not save the PC
Comment 8 Mlenga Matinde 2008-01-19 09:41:09 UTC
Hello, the Kde Crash Handler has informed me about this crash in adept manager...i send this report, thank you mlenga matinde,matindem@agumba.biz