Bug 44367 - Enable a default charset for reading news
Summary: Enable a default charset for reading news
Status: RESOLVED WORKSFORME
Alias: None
Product: knode
Classification: Miscellaneous
Component: general (show other bugs)
Version: 0.7.1
Platform: OpenSUSE Linux
: NOR wishlist with 104 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-06-26 09:33 UTC by Arne Schmitz
Modified: 2009-08-09 18:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arne Schmitz 2002-06-26 09:19:36 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           knode
Version:           0.7.1 (using KDE 3.0.1 )
Severity:          wishlist
Installed from:    SuSE
Compiler:          gcc version 2.95.3 20010315 (SuSE)
OS:                Linux (i686) release 2.4.17
OS/Compiler notes: 

I post news articles using UTF-8 encoding. But there are many users out there using Outlook Express which does not add a "Content-Type" header field in the default configuration. This way Umlauts and other special characters are broken when I read news because KNode thinks the postings are UTF-8 encoded instead of iso-8859-1 or -15. It would be nice to have a setting for a standard encoding when reading news postings that is different from the default encoding (UTF-8 in my case) of KNode.

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 Dalibor Karlović 2006-08-09 23:23:54 UTC
It would be cool to be able to select this per account or per group even.
Comment 2 Dalibor Karlović 2006-08-09 23:24:41 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Olivier Trichet 2009-08-09 18:09:40 UTC
It has long been possible to set a fallback encoding per group.
A fall back per server is requested in bug #198060