Bug 370711 - wallpaper on second monitor is always set to default
Summary: wallpaper on second monitor is always set to default
Status: RESOLVED DUPLICATE of bug 369665
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Image Wallpaper (show other bugs)
Version: master
Platform: Neon Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-13 20:58 UTC by David Heidelberg
Modified: 2016-11-03 16:14 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
plasma1 (43.03 KB, text/plain)
2016-10-15 11:55 UTC, David Heidelberg
Details
plasmarc (104 bytes, text/plain)
2016-10-15 11:56 UTC, David Heidelberg
Details
plasmashellrc (1.01 KB, text/plain)
2016-10-15 11:56 UTC, David Heidelberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Heidelberg 2016-10-13 20:58:47 UTC
It seems that Plasma is not able to remember second screen wallpaper and always set default (after login)

Reproducible: Always




KDE Neon - Developer version
Comment 1 David Edmundson 2016-10-14 00:00:30 UTC
Please can you attach your. config/plasma* files
Comment 2 David Heidelberg 2016-10-15 11:55:59 UTC
Created attachment 101571 [details]
plasma1
Comment 3 David Heidelberg 2016-10-15 11:56:29 UTC
Created attachment 101572 [details]
plasmarc
Comment 4 David Heidelberg 2016-10-15 11:56:51 UTC
Created attachment 101573 [details]
plasmashellrc
Comment 5 David Heidelberg 2016-10-18 10:30:22 UTC
Addional information: when is DP monitor (with wallpaper) shutdown, xrandr reconfigure screen to only ONE display.

Wallpaper is shown.

When is "reconnected" DP monitor, correct wallpaper is still present on VGA output.

I hope it helps
Comment 6 Marco Martin 2016-10-18 11:27:05 UTC
definitely 369665

*** This bug has been marked as a duplicate of bug 369665 ***
Comment 7 David Edmundson 2016-10-27 21:21:13 UTC
Git commit 9331001f4a97a1edb2b2e3f95b591f94abb17c33 by David Edmundson.
Committed on 27/10/2016 at 21:21.
Pushed by davidedmundson into branch 'Plasma/5.8'.

Update screen pool connector ID ordering before adjusting desktop containments

Summary:
Setting the screenpool primary screen changes the mapping of ID ->
connector. We need this to be done before the
DesktopView::setScreenToFollow is called because otherwise it will save
lastScreen with the wrong ID.

Test Plan:
Hot swapped primary, both things swapped.
Restarted Plasma
Things restored as I think they should be.

Reviewers: #plasma

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D3098

M  +2    -1    shell/shellcorona.cpp

http://commits.kde.org/plasma-workspace/9331001f4a97a1edb2b2e3f95b591f94abb17c33