Bug 36120 - kpilot: KPilot corrupts korganizer ical file
Summary: kpilot: KPilot corrupts korganizer ical file
Status: CLOSED FIXED
Alias: None
Product: kpilot
Classification: Applications
Component: General (show other bugs)
Version: unspecified
Platform: unspecified Other
: NOR grave (vote)
Target Milestone: ---
Assignee: groot
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-12-13 10:03 UTC by Daniel Stone
Modified: 2004-10-19 16:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Stone 2001-12-13 09:59:57 UTC
(*** This bug was imported into bugs.kde.org ***)



Package: kpilot
Severity: grave
Justification: renders package unusable

------
This bug is forwarded from the Debian BTS as it was filed on
a Debian package.
The original bug report can be seen at http://bugs.debian.org/123634.
As far as I know it is not a duplicate of any existing bug.
If it is I will pick this up and merge within the next 12 hours;
Otherwise please merge yourself.
Thankyou Daniel Stone <daniel@sfarc.net> the "other"
Debian KDE maintainer.
------

When syncronizing the korganiser file with kpilot I get the following error
message:

The vcal conduit could not open the file 
&quot;/home/florian/.kde/share/apps/korganizer/florian.ics&quot;. Please setup the 
conduit with the correct filename and try again.

But the file exists. After this error message it isn't usable for korganizer 
either.

Greets

Florian

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux lukas 2.4.13 #1 Sam Nov 10 19:49:16 CET 2001 i586
Locale: LANG=de_DE@euro LC_CTYPE=de_DE@euro

Versions of packages kpilot depends on:
ii  kdelibs3               4:2.2.2-4         KDE core libraries (runtime 
files)
ii  kdepim-libs            4:2.2.2-2         KDE libraries amd modules for 
kdep
ii  libc6                  2.2.4-6           GNU C Library: Shared libraries 
an
ii  libjpeg62              6b-4              The Independent JPEG Group's 
JPEG 
ii  libpisock4             0.9.5.0-6         Libraries for communicating with 
a
ii  libpng2                1.0.12-2          PNG library - runtime
ii  libqt2                 3:2.3.1-17        Qt GUI Library (runtime version).
ii  libstdc++2.10-glibc2.2 1:2.95.4-0.011006 The GNU stdc++ library
ii  pilot-link             0.9.5.0-6         Tools to communicate with a 3COM 
P
ii  xlibs                  4.1.0-9           X Window System client libraries
ii  zlib1g                 1:1.1.3-18        compression library - runtime
Comment 1 Daniel Stone 2001-12-18 01:41:49 UTC
FYI.

----- Forwarded message from "L. Vogtmann" <vmann@vmann.net> -----

Subject: Bug#123634: kpilot: No "--debug" option to kpilotDaemon
From: "L. Vogtmann" <vmann@vmann.net>
To: Debian Bug Tracking System <123634@bugs.debian.org>
Date: Fri 14 Dec 2001 21:08:57 -0800

Package: kpilot
Version: 4:2.2.2-3

I'm having the same problem with the korganizer conduit.
I tried the above mentioned "--debug 1023" option non-existant.
I did however get it to spew some useful information with "--nofork"
(only once though can't reproduce reliably)
"it seems a conduit has crashed"

When the conduit does complete and sync appears to work correctly both the
korganizer file and palm datebook database are wiped clean (even with the
checkbox marked for "prompt before changing data.")  That checkbox is also
then cleared.  (I'm not sure about this maybe my head playing tricks on me?)

Also not sure how relevant it is but the *.icl.bak file is completely
emptied on each run.  Crash or not.

HTH

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux tank 2.4.14 #1 Mon Nov 26 18:41:50 PST 2001 i686
Locale: LANG=C LC_CTYPE=C

Versions of packages kpilot depends on:
ii  kdelibs3               4:2.2.2-6         KDE core libraries (runtime files)
ii  kdepim-libs            4:2.2.2-3         KDE libraries amd modules for kdep
ii  libc6                  2.2.4-7           GNU C Library: Shared libraries an
ii  libjpeg62              6b-4              The Independent JPEG Group's JPEG 
ii  libpisock4             0.9.5.0-6         Libraries for communicating with a
ii  libpng2                1.0.12-2          PNG library - runtime
ii  libqt2                 3:2.3.1-17        Qt GUI Library (runtime version).
ii  libstdc++2.10-glibc2.2 1:2.95.4-0.011006 The GNU stdc++ library
ii  pilot-link             0.9.5.0-6         Tools to communicate with a 3COM P
ii  xlibs                  4.1.0-11          X Window System client libraries
ii  zlib1g                 1:1.1.3-18        compression library - runtime



----- End forwarded message -----

-- 
Daniel Stone    <daniel@sfarc.net>
"That will have to do for now old boy the pavilion appears to be on fire."
-- English cricket writer Dickie Rutnagur cheerfully wrapping up a report 
from India.
Comment 2 Daniel Stone 2001-12-18 01:42:18 UTC
Again; looks like it's in the repeat-event handling.

----- Forwarded message from "L. Vogtmann" <vmann@vmann.net> -----

Subject: Bug#123634: kpilot: Problem solved for me at least
From: "L. Vogtmann" <vmann@vmann.net>
To: Debian Bug Tracking System <123634@bugs.debian.org>
Date: Sat 15 Dec 2001 18:13:37 -0800

Package: kpilot
Version: 4:2.2.2-3

Answer found in the korganizer manual.  Shut down korganizer (including the
alarm daemon)!  This solved it for me.  Maybe that should be more prominent in
the kpilot documentation as well.  (Or shutdown korganizer and the alarm daemon
as part of the conduit if that is possible.)

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux tank 2.4.14 #1 Mon Nov 26 18:41:50 PST 2001 i686
Locale: LANG=C LC_CTYPE=C

Versions of packages kpilot depends on:
ii  kdelibs3               4:2.2.2-6         KDE core libraries (runtime files)
ii  kdepim-libs            4:2.2.2-3         KDE libraries amd modules for kdep
ii  libc6                  2.2.4-7           GNU C Library: Shared libraries an
ii  libjpeg62              6b-4              The Independent JPEG Group's JPEG 
ii  libpisock4             0.9.5.0-6         Libraries for communicating with a
ii  libpng2                1.0.12-2          PNG library - runtime
ii  libqt2                 3:2.3.1-17        Qt GUI Library (runtime version).
ii  libstdc++2.10-glibc2.2 1:2.95.4-0.011006 The GNU stdc++ library
ii  pilot-link             0.9.5.0-6         Tools to communicate with a 3COM P
ii  xlibs                  4.1.0-11          X Window System client libraries
ii  zlib1g                 1:1.1.3-18        compression library - runtime



----- End forwarded message -----
----- Forwarded message from "L. Vogtmann" <vmann@vmann.net> -----

Subject: Bug#123634: kpilot: "Repeat" events the heart of ical file corruption
From: "L. Vogtmann" <vmann@vmann.net>
To: Debian Bug Tracking System <123634@bugs.debian.org>
Date: Sun 16 Dec 2001 01:46:39 -0800

Package: kpilot
Version: 4:2.2.2-3

OK after trying some more same bug.  Think it's in the repeat event handling.
Here's a blank ical file to start with:

BEGIN:VCALENDAR
PRODID
 :-//K Desktop Environment//NONSGML KOrganizer 2.2.1//EN
VERSION
 :2.0
END:VCALENDAR

Next add a wake-up event for every weekday with korganizer:

BEGIN:VCALENDAR
PRODID
 :-//K Desktop Environment//NONSGML KOrganizer 2.2.1//EN
VERSION
 :2.0
BEGIN:VEVENT
CREATED
 :20011216T013255
UID
 :KOrganizer-219794112.723
SEQUENCE
 :0
LAST-MODIFIED
 :20011216T013255
DTSTAMP
 :20011216T013259
ORGANIZER
 :MAILTO:vmann@vmann.net
DTSTART
 :20011217T050000
SUMMARY
 :wake-up
CLASS
 :PUBLIC
PRIORITY
 :1
X-PILOTID
 :0
X-PILOTSTAT
 :1
RRULE
 :FREQ=WEEKLY;INTERVAL=1;BYDAY=MOTUWETHFR
DTEND
 :20011217T060000
END:VEVENT
END:VCALENDAR

Now we sync with kpilot. Sync goes fine but the event shows up in Datebook as
Sunday through Thursday!

Now I start over deleting event on palm and reverting to original korganizer
file.

And now add the same event from the palm Datebook app.
Sync this dialog appears.

ToDo Conduit Fatal Error
The ToDo Conduit could not open the file `/home/vmann/.kde/share/apps/korganizer/vmann.ics'. Please configure the conduit with the correct filename and try again.

And the contents of the ics file:

BEGIN:VCALENDAR
PRODID
 :-//K Desktop Environment//NONSGML KOrganizer 2.2.1//EN
VERSION
 :2.0
BEGIN:VEVENT
CREATED
 :20011216T014015
UID
 :KOrganizer-525089956.403
SEQUENCE
 :0
LAST-MODIFIED
 :20011216T014015
DTSTAMP
 :20011216T014015
ORGANIZER
 :MAILTO:unknown@nowhere
DTSTART
 :20011217T050000
SUMMARY
 :wake-up
CLASS
 :PUBLIC
PRIORITY
 :1
X-PILOTID
 :8573060
X-PILOTSTAT
 :0
RRULE
 :FREQ=WEEKLY;UNTIL=29350930228T000000;INTERVAL=1;BYDAY=MOTUWETHFR
DTEND
 :20011217T060000
END:VEVENT
END:VCALENDAR

I hope this helps out.

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux tank 2.4.14 #1 Mon Nov 26 18:41:50 PST 2001 i686
Locale: LANG=C LC_CTYPE=C

Versions of packages kpilot depends on:
ii  kdelibs3               4:2.2.2-6         KDE core libraries (runtime files)
ii  kdepim-libs            4:2.2.2-3         KDE libraries amd modules for kdep
ii  libc6                  2.2.4-7           GNU C Library: Shared libraries an
ii  libjpeg62              6b-4              The Independent JPEG Group's JPEG 
ii  libpisock4             0.9.5.0-6         Libraries for communicating with a
ii  libpng2                1.0.12-2          PNG library - runtime
ii  libqt2                 3:2.3.1-17        Qt GUI Library (runtime version).
ii  libstdc++2.10-glibc2.2 1:2.95.4-0.011006 The GNU stdc++ library
ii  pilot-link             0.9.5.0-6         Tools to communicate with a 3COM P
ii  xlibs                  4.1.0-11          X Window System client libraries
ii  zlib1g                 1:1.1.3-18        compression library - runtime



----- End forwarded message -----

-- 
Daniel Stone    <daniel@sfarc.net>
<Oskuro> Overfiend: many patches on top of 4.0.1 already?
<Overfiend> Oskuro: a few
<Overfiend> only 152 megs
Comment 3 Klaus Ramst 2002-04-21 18:45:16 UTC
I suffered from the same bug. I was able to recover my icsfile by removing the
UNTIL in RRULE (see also mail by L. Vogtmann):

BAD:
>RRULE
> :FREQ=WEEKLY;UNTIL=29350930228T000000;INTERVAL=1;BYDAY=MOTUWETHFR
GOOD:
<RRULE
<:FREQ=WEEKLY;NTERVAL=1;BYDAY=MOTUWETHFR

I suggest that the parser tells where he chokes.

Klaus
-- 
klaus@ramstock.de  - http://www.ramstock.de
Comment 4 groot 2002-08-28 13:09:11 UTC
KPilot now uses the same library (libkcal) as KOrganizer for manipulating
the ical files; in addition it now checks to make sure that KOrganizer
isn't running when the conduit does a sync.

-- 
+------------------------------+--------------------------------------------+
+ Adriaan de Groot             + Project: FRESCoS                           +
+ adridg@cs.kun.nl             + Private: adridg@sci.kun.nl                 +
+ Kamer A6020 tel. 024 3652272 + http://www.cs.kun.nl/~adridg/frescos/      +