Bug 35582 - Crashes when I try to load a config file
Summary: Crashes when I try to load a config file
Status: RESOLVED WORKSFORME
Alias: None
Product: kcontrol
Classification: Miscellaneous
Component: kcmlinuz (show other bugs)
Version: unspecified
Platform: unspecified Other
: NOR crash (vote)
Target Milestone: ---
Assignee: Malte Starostik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-11-30 07:03 UTC by Ivan E. Moore II
Modified: 2003-11-03 07:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace (2.53 KB, text/plain)
2002-10-31 05:47 UTC, Wim Toremans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan E. Moore II 2001-11-30 07:01:53 UTC
(*** This bug was imported into bugs.kde.org ***)

Package: kcmlinuz
Version: 2.2.2

If this problem is general severity should be higher.

I click on the KDE control center icon and select System | Linux
Kernel Configurator.
Then I click "Load From" and navigate to a copy of the configuration
file save under /boot by kernel-package (? not sure that's the exact
name--the debian way of building kernels).  I select the file hit OK
and it crashes.

I thought it might be a permission issue so I copied config-2.4.12 to
my home directory and changed ownership.  Still crashes repeatably.

I thought it might be that the default path to the source is not
present on my system but setting it first and then loading the config
file still crashes.

After I set the path I get the following error displayed in the main
panel of the KDE Control Center:
        The kernel configuration could not be read due to the following error:

        cannot open /usr/local/src/kernel-source-2.4.14//arch//config.in for
        readingEither your kernel sources contain invalid configuration rules
        or you just found a bug in the KDE Kernel Configurator.


Here's the trace from the panel that told me the KDE Control Center
had crashed:

(no debugging symbols found)...0x40d3b8f9 in wait4 () from /lib/libc.so.6
#0  0x40d3b8f9 in wait4 () from /lib/libc.so.6
#1  0x40db41f0 in __check_rhosts_file () from /lib/libc.so.6
#2  0x40590c88 in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.3

#3  0x40cc4848 in sigaction () from /lib/libc.so.6
#4  0x4101b9cd in Configuration::loadConfig () from /usr/lib/libkcm_linuz.so
#5  0x4101b677 in Configuration::slotLoadFrom () from /usr/lib/libkcm_linuz.so

#6  0x407d8b1a in QObject::activate_signal () from /usr/lib/libqt.so.2
#7  0x408e2bbd in QButton::clicked () from /usr/lib/libqt.so.2
#8  0x408361f5 in QButton::mouseReleaseEvent () from /usr/lib/libqt.so.2
#9  0x4081dd72 in QWidget::event () from /usr/lib/libqt.so.2
#10 0x407880a6 in QApplication::notify () from /usr/lib/libqt.so.2
#11 0x404ff994 in KApplication::notify () from /usr/lib/libkdecore.so.3
#12 0x40759360 in QETWidget::translateMouseEvent () from /usr/lib/libqt.so.2
#13 0x40756c72 in QApplication::x11ProcessEvent () from /usr/lib/libqt.so.2
#14 0x40755c9a in QApplication::processNextEvent () from /usr/lib/libqt.so.2
#15 0x40789df4 in QApplication::enter_loop () from /usr/lib/libqt.so.2
#16 0x40755c17 in QApplication::exec () from /usr/lib/libqt.so.2
#17 0x40f19aa3 in main () from /usr/lib/kde2/kcontrol.so
#18 0x0804ccd6 in QCollection::newItem ()
#19 0x0804d8f8 in QCollection::newItem ()
#20 0x0804dd95 in QCollection::newItem ()
#21 0x0804edd6 in QCollection::newItem ()
#22 0x40cb465f in __libc_start_main () from /lib/libc.so.6

-- 
----------------
Ivan E. Moore II
rkrusty@tdyc.com
http://snowcrash.tdyc.com
GPG KeyID=90BCE0DD
GPG Fingerprint=F2FC 69FD 0DA0 4FB8 225E 27B6 7645 8141 90BC E0DD
Comment 1 Malte Starostik 2001-11-30 20:53:24 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Am Friday 30 November 2001 08:01 schrieben Sie:
> Package: kcmlinuz
> Version: 2.2.2
>
> If this problem is general severity should be higher.
>
> I click on the KDE control center icon and select System | Linux
> Kernel Configurator.
> Then I click "Load From" and navigate to a copy of the configuration
> file save under /boot by kernel-package (? not sure that's the exact
> name--the debian way of building kernels).  I select the file hit OK
> and it crashes.
>
> I thought it might be a permission issue so I copied config-2.4.12 to
> my home directory and changed ownership.  Still crashes repeatably.
>
> I thought it might be that the default path to the source is not
> present on my system but setting it first and then loading the config
> file still crashes.
>
> After I set the path I get the following error displayed in the main
> panel of the KDE Control Center:
>         The kernel configuration could not be read due to the following
> error:
>
>         cannot open /usr/local/src/kernel-source-2.4.14//arch//config.in
> for readingEither your kernel sources contain invalid configuration rules
> or you just found a bug in the KDE Kernel Configurator.
//arch//config.in
should be //arch/i386/config.in or whatever platform you're building for. Is 
that source tree readable for the user you're running kcontrol as?
Either way none of these situations should crash the app I'll look into it.

[snip]

Thanks for the report
- -- 
Malte Starostik
PGP: 1024D/D2F3C787 [C138 2121 FAF3 410A 1C2A  27CD 5431 7745 D2F3 C787]
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.4 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE8B/HGVDF3RdLzx4cRAm9XAJ4qIZwyTkBmDHs6zvMdoBM66aqLSgCaA/vu
iu624Z+qaOkER4QUMtVWIaY=
=7G4y
-----END PGP SIGNATURE-----
Comment 2 Ivan E. Moore II 2001-12-01 01:23:38 UTC
On Fri Nov 30 2001 at 09:53:24PM +0100 Malte Starostik wrote:
> Am Friday 30 November 2001 08:01 schrieben Sie:
> > Package: kcmlinuz
> > Version: 2.2.2
> >
> > If this problem is general severity should be higher.
> >
> > I click on the KDE control center icon and select System | Linux
> > Kernel Configurator.
> > Then I click "Load From" and navigate to a copy of the configuration
> > file save under /boot by kernel-package (? not sure that's the exact
> > name--the debian way of building kernels).  I select the file hit OK
> > and it crashes.
> >
> > I thought it might be a permission issue so I copied config-2.4.12 to
> > my home directory and changed ownership.  Still crashes repeatably.
> >
> > I thought it might be that the default path to the source is not
> > present on my system but setting it first and then loading the config
> > file still crashes.
> >
> > After I set the path I get the following error displayed in the main
> > panel of the KDE Control Center:
> >         The kernel configuration could not be read due to the following
> > error:
> >
> >         cannot open /usr/local/src/kernel-source-2.4.14//arch//config.in
> > for readingEither your kernel sources contain invalid configuration rules
> > or you just found a bug in the KDE Kernel Configurator.
> //arch//config.in
> should be //arch/i386/config.in or whatever platform you're building for. Is 
> that source tree readable for the user you're running kcontrol as?
> Either way none of these situations should crash the app I'll look into it.

yes it is.

Ivan

-- 
----------------
Ivan E. Moore II
rkrusty@tdyc.com
http://snowcrash.tdyc.com
GPG KeyID=90BCE0DD
GPG Fingerprint=F2FC 69FD 0DA0 4FB8 225E 27B6 7645 8141 90BC E0DD
Comment 3 Wim Toremans 2002-10-31 05:47:43 UTC
Created attachment 333 [details]
Backtrace
Comment 4 Wim Toremans 2002-10-31 05:48:19 UTC
Hi, I currently experience the same problem as Ivan is having.   Happens after loading a .config file from /usr/src/2.4.19 or when loading a copied version of this .config file. When selecting the file I get the preview and just after clicking ok kernel configurator closes giving me the following output:  The application KDE Control Module (kcmshell) crashed and caused the signal 11.  Attached you can also find my backtrace.  Greetings,  Wim Toremans bugzilla@wimmeke.com Brussels, Belgium   
Comment 5 George Staikos 2003-02-16 05:25:11 UTC
Can you either provide the config files, or rebuild and provide a backtrace with 
debugging symbols please?  I cannot reproduce this with 2.4.19 source. 
 
Comment 6 Daniel Molkentin 2003-11-03 07:56:34 UTC
No response from reporter for more than a year. Neither george nor I can reproduce it.