Bug 353232 - Audio Volume system settings regression from Kmix: Moving audio to a different output device.
Summary: Audio Volume system settings regression from Kmix: Moving audio to a differe...
Status: RESOLVED FIXED
Alias: None
Product: plasma-pa
Classification: Unclassified
Component: general (show other bugs)
Version: 5.4.1
Platform: Debian testing Linux
: NOR wishlist
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 351367 355129 356189 (view as bug list)
Depends on: 351367
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-27 12:19 UTC by Arthur Moore
Modified: 2016-04-02 15:23 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arthur Moore 2015-09-27 12:19:52 UTC
The previous (kmix) system tray icon allowed for pulling up a mixer with a list of individual playback streams.  This was provided by a prominent button labeled "Mixer".

The new Audio Volume widget provides a right click menu to access the "Audio Volume" system settings menu.  This menu provides the same information as Kmix, excluding the missing icons and event sounds bar.  Unfortunately, it does not provide a method to move applications' audio to a different output.  Kmix allows for this using a "right click -> move" option.

Reproducible: Always

Steps to Reproduce:
0.  Have more than one audio output device
1.  Open old Kmix mixer
2.  Select the "Playback Streams" tab.
3.  Start playing some audio
4.  Right click the audio icon on the "Playback Streams" tab
5.  Select Move, and move to another audio device

Actual Results:  
0.  Open "Audio Volume" System settings.
1.  Notice That application icons are missing.
2.  Note that right clicking does nothing.

Expected Results:  
0.  Open "Audio Volume" System settings.
1.  Application icons are shown.
2.  Have an option to select which audio output is used by the application.
2a.  Optionally show each application's current audio output (combo box?)

I have a USB headset, mixed with regular speakers.  The ability to switch applications between them is essential to my use case.  Since I'm, probably, in the minority I'll just continue using Kmix and this can go in the wishlist.
Comment 1 David Edmundson 2015-12-02 08:46:57 UTC
*** Bug 356189 has been marked as a duplicate of this bug. ***
Comment 2 David Rosca 2016-04-02 09:54:53 UTC
*** Bug 355129 has been marked as a duplicate of this bug. ***
Comment 3 David Rosca 2016-04-02 10:11:47 UTC
*** Bug 351367 has been marked as a duplicate of this bug. ***
Comment 5 quentin.denis 2016-04-02 15:23:39 UTC
Great!!! Thanks!