Bug 351699 - Whereis Share Folder
Summary: Whereis Share Folder
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kio
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 354127 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-24 14:16 UTC by Gilberto Ferreira
Modified: 2015-10-20 21:06 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Here's a screenshot... (61.20 KB, image/png)
2015-08-24 14:16 UTC, Gilberto Ferreira
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gilberto Ferreira 2015-08-24 14:16:36 UTC
Created attachment 94203 [details]
Here's a screenshot...

Hi

I am using KDE Plasm from Kubuntu Willy WereWolf...
Everything is ok, except that I can use share folder in Dolhin File Manager.
I can't found the sharing tab in propertiers menu context.
I am sending a screenshot attached, although is in PT_BR...

Thanks a lot
Comment 1 Frank Reininghaus 2015-08-25 19:53:33 UTC
Thanks for the bug report! The "Properties" dialog is part of the KIO framework, so I'll reassign.
Comment 2 Gilberto Ferreira 2015-08-25 22:33:38 UTC
Thanks!
Comment 3 Gilberto Ferreira 2015-08-28 11:24:53 UTC
Actually, I miss many features that I found in previously releases, like unpack here, open terminal here, and of course, the share tab in propierties context menu...
Perhaps is something that I don't installed... Some services package???
Comment 4 Gilberto Ferreira 2015-10-03 14:02:09 UTC
Again, where is the damn tab to share files and folders?!?!?! Every Time I need share something to somebody at network, I need directly edit the samba file (smb.conf). This is annoying!!!
I am using last Wily WhereWolf distro... Everything is up to date via apt-get...
Perhaps I need do something?!?!?
Comment 5 David Faure 2015-10-03 15:14:28 UTC
The "Share" tab in the properties dialog is implemented by a plugin that lives in
kdenetwork/kdenetwork-filesharing/samba/filepropertiesplugin

This code has a "frameworks" branch, but it hasn't been released yet.

This is one of these transition issues due to the current mix-and-match between the Qt4 and the Qt5 based code.
Not sure who maintains kdenetwork-filesharing, to reassign this issue.....
Comment 6 Harald Sitter 2015-10-05 10:45:13 UTC
Rodrigo Belem is the closest the plugin has seen to a maintainer in a while. I asked him on IRC if he considers himself to be maintainer, waiting for a reply.

Meanwhile I spent some time finishing up the port. Except for the packagekit code, which I can't test right now, it seems to work well enough to get merged. A bit of reviewing would be handy though.
All in all it is very straight-forward, the only non-port activity was switching out the packagekit dbus usage for actual packagekit-qt API which all in all should be a change for the better.

Once merged I'd suggest to pull a standalone tarball versioned 15.10.0 as a stopgap until we can release kdenetwork-filesharing as part of applications 15.12.
Comment 7 Albert Astals Cid 2015-10-05 12:14:48 UTC
Adding Urs as the point of contact on the release team for kdenetwork
Comment 8 Jonathan Riddell 2015-10-05 12:39:59 UTC
Adding Ranveer to CC.  Ranveer is my GSoC student who started the frameworks port

Last we chatted he was still working out how to update the UI when packagekit reports the package is installed.  

Our todo list for this project says:
"filesharing branch: merge frameworks into master and ask for testers on dolphin mailing list move kdenetworks-filesharing into dolphin or dolphin-plugins tell packagers about settings -DSAMBA_PACKAGE_NAME= "
Comment 9 Albert Astals Cid 2015-10-14 23:23:22 UTC
Riddell has merged this into master so it'll be released next time.
Comment 10 Frank Reininghaus 2015-10-20 21:06:29 UTC
*** Bug 354127 has been marked as a duplicate of this bug. ***