Bug 342335 - Notification about finish update of TM in lokalize with Open button; pressing gives error notification
Summary: Notification about finish update of TM in lokalize with Open button; pressing...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Notifications (show other bugs)
Version: 5.1.2
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Martin Klapetek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-30 13:13 UTC by Freek de Kruijf
Modified: 2019-05-13 07:12 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screendump from popup (33.06 KB, image/png)
2014-12-30 13:15 UTC, Freek de Kruijf
Details
screendump of notification message with Open button (40.53 KB, image/png)
2014-12-31 15:25 UTC, Freek de Kruijf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Freek de Kruijf 2014-12-30 13:13:13 UTC
Using lokalize and pressing F7 (TM) and pressing Scan all files in the project.
This finally gives a notification with an Open button. Pressing that button gives an Error popup showing the non-existance of /usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/kde4-nl See attached picture.

Reproducible: Didn't try
Comment 1 Freek de Kruijf 2014-12-30 13:15:08 UTC
Created attachment 90169 [details]
Screendump from popup
Comment 2 Martin Klapetek 2014-12-30 13:26:57 UTC
I assume that's running on kde4?
Comment 3 Freek de Kruijf 2014-12-30 13:34:28 UTC
It is a mix of KDE4 and Framework 5 on openSUSE Tumbleweed.
Comment 4 Martin Klapetek 2014-12-30 14:01:08 UTC
Ok; is that running on Plasma5? Is Lokalize frameworks based or kdelibs/qt4 based? I just need to know the combination of KNotification and Plasma used in this case.

Finally, do you know if that notification is spawned directly by Lokalize or by some other library/process?
Comment 5 Freek de Kruijf 2014-12-30 23:17:55 UTC
I just installed plasma 5 modules in openSUSE Tumbleweed which are part of the general repository of this version of the distribution. They coexist with the old platform. When making a list of packages with kf5 in it, which are installed, it amounts to quite a number. I guess it is about 40-50. I notice that notification in this system is quite different from the one in openSUSE 13.2 in which I only use KDE 4.14.3. So I assume this notification comes from Plasma 5. I do not have the impression that lokalize itself is based on Plasma 5. So I assume the notification from lokalize uses the standard communication between the notification widget in the system tray and lokalize.

Please give some hints about how to provide the needed information.
Comment 6 Freek de Kruijf 2014-12-31 15:23:26 UTC
With lsof I looked at files used by lokalize. None of these had kf5 in its name.
The message shown by the Notifications widget, after the scanning is done without an error, contains an Open button (see attachment), however this button is not present when using only KDE 4.14.3. Pressing that button activates the command:
/bin/sh /usr/bin/xdg-open file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/kde4-nl , which in turn activates the command:
kde-open5 file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/kde4-nl
I can't think of anything that needs to be opened when lokalize finishes the scanning.
Comment 7 Freek de Kruijf 2014-12-31 15:25:15 UTC
Created attachment 90182 [details]
screendump of notification message with Open button
Comment 8 Martin Klapetek 2015-01-01 15:11:35 UTC
Ok so this looks like a bug in Plasma 5 notifications, not the framework.

Can you please translate what the notification says? I suspect that lokalize starts some KJob after pressing F7; Plasma 5 adds the "Open" button automatically when the job finishes and when there is something to open. We may have have a bug in there.

Which Plasma 5 version is that?
Comment 9 Freek de Kruijf 2015-01-02 14:59:52 UTC
The notification in English should be:
Files added to Translation Memory......
It is strange that I can't find this string in any .po file.
The only string that comes close is:
Adding files to Lokalize translation memory
which is translated as:
Bestanden aan vertaalgeheugen van Lokalize toevoegen
Comment 10 Freek de Kruijf 2015-01-02 15:03:24 UTC
(In reply to Martin Klapetek from comment #8)
> Which Plasma 5 version is that?

I see package:
plasma5-desktop-5.1.2-1.1
same version plasma-workspace
Comment 11 Bhushan Shah 2015-01-18 15:45:27 UTC
I guess, I think this is something like bug in Lokalize that it is not passing correct url for open action.
Comment 12 Martin Klapetek 2015-01-19 14:25:36 UTC
I don't think there should be any open action, in fact, I'm not sure that this job should be in the job tracker at all.
Comment 13 Kai Uwe Broulik 2019-05-13 07:12:08 UTC
I think this should be fixed with the new notification system as it has a batter URL identification heuristic. Feel free to re-open if this issue persists in Plasma 5.16