Bug 333317 - Sorting tasks creates an icon
Summary: Sorting tasks creates an icon
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Panel (show other bugs)
Version: master
Platform: unspecified Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-11 12:25 UTC by Antonio Rojas
Modified: 2014-04-17 16:31 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2014-04-11 12:25:29 UTC
Manually dragging and dropping a task inside the taskbar creates an icon of the dragged application on the panel. The icon should only be created if the task is dropped between two pasmoids, not anywhere in the panel.

Reproducible: Always
Comment 1 Marco Martin 2014-04-11 15:41:55 UTC
icon is not created anymore, spacers are still created, still not optimal
Comment 2 Marco Martin 2014-04-17 10:31:59 UTC
I think that's related with
https://bugreports.qt-project.org/browse/QTBUG-30305

(note that even if we use another implementation of the QML DropArea, the problem is actually on the shared underlying dropEvent implementation in QQuickItem)
Comment 3 Marco Martin 2014-04-17 16:28:17 UTC
Git commit 67fbd0354efaa9dc19211b102ce94faf0aa07de8 by Marco Martin.
Committed on 17/04/2014 at 16:22.
Pushed by mart into branch 'master'.

new property: preventStealing

this, consistent with MouseArea::preventStealing, will make sure
that a droparea with it will take the exclusive of all dropevents,
all its parents (all up the hyerarchy to top) won't take any
as long as this is managing

M  +61   -1    src/qmlcontrols/draganddrop/DeclarativeDropArea.cpp
M  +17   -1    src/qmlcontrols/draganddrop/DeclarativeDropArea.h

http://commits.kde.org/kdeclarative/67fbd0354efaa9dc19211b102ce94faf0aa07de8
Comment 4 Marco Martin 2014-04-17 16:31:18 UTC
Git commit 14c5bd3043c2563204880437c7295c0973d8dacc by Marco Martin.
Committed on 17/04/2014 at 16:29.
Pushed by mart into branch 'master'.

use preventStealing in the taskmanager

the taskmanager will take the exclusive in threating all drop events, not colliding with the Panel dnd anymore

M  +1    -0    applets/taskmanager/package/contents/ui/MouseHandler.qml
M  +1    -5    containments/panel/contents/ui/main.qml

http://commits.kde.org/plasma-desktop/14c5bd3043c2563204880437c7295c0973d8dacc