Bug 332869 - System tray animates when opened from a different tab
Summary: System tray animates when opened from a different tab
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: System Tray (show other bugs)
Version: master
Platform: unspecified Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on: 332884
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-31 16:01 UTC by David Edmundson
Modified: 2014-04-07 16:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Image dump from apitrace (139.71 KB, image/gif)
2014-03-31 16:27 UTC, David Edmundson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Edmundson 2014-03-31 16:01:02 UTC
If I click on the battery applet in the system tray when the expanded view appears I can see it animate a fade from "Status and Notifications"
Comment 1 David Edmundson 2014-03-31 16:27:16 UTC
It looks like there is code trying to solve this.
There is a timer  which disables animation for the first 500ms for the page stack. This is somewhat hacky and doesn't always work

More importantly this doesn't include the header.

I'll assign this to me.
Comment 2 David Edmundson 2014-03-31 16:27:43 UTC
Created attachment 85872 [details]
Image dump from apitrace
Comment 3 David Edmundson 2014-03-31 20:51:15 UTC
I fixed the header (will push after split settles down, please poke me \)
 
Page stack still has a bug in it, opened with a test case.
Comment 4 Bhushan Shah 2014-04-03 12:16:08 UTC
*poke*
Comment 5 David Edmundson 2014-04-03 12:56:20 UTC
Oh. I pushed my part of the patch. I can't close this whilst there's a blocking bug.
Comment 6 Marco Martin 2014-04-03 16:08:17 UTC
Git commit 2f10450c179bc13e224784099911b723ed02b1ef by Marco Martin.
Committed on 03/04/2014 at 16:07.
Pushed by mart into branch 'master'.

make the animate property do something
Related: bug 332884

M  +3    -3    src/declarativeimports/plasmacomponents/qml/PageStack.qml

http://commits.kde.org/plasma-framework/2f10450c179bc13e224784099911b723ed02b1ef
Comment 7 Marco Martin 2014-04-07 16:50:51 UTC
Not reproduceable anymore after last commit