Bug 332159 - dolphin does not remember scroll position when going back
Summary: dolphin does not remember scroll position when going back
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.12.1
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-14 22:04 UTC by illumilore
Modified: 2014-04-24 18:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.13.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description illumilore 2014-03-14 22:04:38 UTC
I open up dolphin and navigate to a folder with many subfolders in it. I scroll down to the bottom and click the bottom subfolder, then I hit back. After going back, my scroll position is reset and I am back at the top. Given that this makes me lose my scroll place (which is annoying when you have a thousand folders) and that I think other folder explorers remember position when going back, dolphin should remember it's scroll position.

Reproducible: Always
Comment 1 Frank Reininghaus 2014-03-15 09:56:10 UTC
Thanks for the bug report, but I cannot reproduce the problem. Tried Dolphin 4.12.3 in various view modes, going back using the toolbar button and with Alt+Left, but it always works fine for me.

(In reply to comment #0)
> Reproducible: Always

Then please provide some more details, like the view mode and all other settings that are required to see the bug. When in doubt if your description is detailed enough, try if it is sufficient to reproduce the problem with a new user. Sometimes a screenshot or screencast might also help.

Thanks for your help.
Comment 2 illumilore 2014-03-15 21:29:41 UTC
I tested it in a new profile and on my laptop. It happened in all cases, and in any view mode (icon, compact or detail), and happened whether I hit back mouse button, alt+left, or clicked on back icon. Dolphin never remembers the scroll position in any case.

kde Platform Version 4.12.3
Dolphin
Version 4.12.3
Opensuse x64 13.1
Comment 3 Emmanuel Pescosta 2014-03-16 13:25:23 UTC
I can't reproduce it either (tested in Dolphin 4.12.3, 4.12.80 and master)

When you open a folder (e.g. A) and go back, is this folder (e.g. A) underlined?
Comment 4 illumilore 2014-03-16 17:51:59 UTC
Yes.
Comment 5 Ashish 2014-03-23 18:02:46 UTC
I can reproduce this only when the 1st folder has "Show hidden files" enabled. 
Step 1: Enable Show Hideen Files in say, home folder.
2: Scroll down, open any folder.
3: click back. We reach the top position in home folder.

When Hidden files is not enabled, clicking on back remembers the scroll position.

Version tested: 4.12.3 on Ubuntu 13.10
Comment 6 Emmanuel Pescosta 2014-03-23 18:11:56 UTC
@Ashish: Thanks for the info, really helpful! :)

I'll try to reproduce and hopefully fix it, when I'm in front of my machine again.
Comment 7 Emmanuel Pescosta 2014-03-24 11:52:35 UTC
Can reproduce it on my machine.

Steps are in Ashish's comment. (#5)
Comment 8 Frank Reininghaus 2014-03-24 22:30:20 UTC
Thanks - it's good to know that it's reproducible now :-)

One thing that I have to add after first trying unsuccessfully to reproduce it: It's only reproducible if "Show Hidden Files" is enabled in the folder whose state is to be restored, and disabled (i.e., no hidden files shown) in the previously visited folder.
Comment 9 Emmanuel Pescosta 2014-04-24 18:23:13 UTC
Git commit 4da1c81d63c19428f81a0af7cb23994c7881a675 by Emmanuel Pescosta.
Committed on 24/04/2014 at 18:16.
Pushed by emmanuelp into branch 'KDE/4.13'.

Scroll to the right position when going back and show hidden files is enabled.

Instead of emitting the directoryLoadingCompleted signal (via slotCompleted) in
KFileItemModel::setShowHiddenFiles directly, we now call
dispatchPendingItemsToInsert instead.

@Frank: Thanks for your help!

FIXED-IN: 4.13.1
REVIEW: 117021

M  +1    -1    dolphin/src/kitemviews/kfileitemmodel.cpp

http://commits.kde.org/kde-baseapps/4da1c81d63c19428f81a0af7cb23994c7881a675