Bug 330115 - The plasma-media center displays the time in AM between 12 noon and 1pm .
Summary: The plasma-media center displays the time in AM between 12 noon and 1pm .
Status: RESOLVED FIXED
Alias: None
Product: plasma-mediacenter
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: R.Harish Navnit
URL: https://docs.google.com/file/d/0Bxf5Q...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-18 10:02 UTC by R.Harish Navnit
Modified: 2014-03-15 08:18 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Using time data engine solves this issue too . (2.41 KB, patch)
2014-02-11 09:20 UTC, heenamahour
Details

Note You need to log in before you can comment on or make changes to this bug.
Description R.Harish Navnit 2014-01-18 10:02:10 UTC
I just happened to run the plasma-mediacenter in the noon (between 12-1) and to my surprise I found the time being displayed as "0:11 AM" . But when I run it now , it displays the time properly.

Reproducible: Didn't try

Steps to Reproduce:
1.Run the plasma-mediacenter 
2.Check the time being displayed 
3.The time displayed will most likely be wrong between 12 noon to 1 pm .
Actual Results:  
I just encountered this error once so far . I'll have to wait 24 hours to see if the error persists .

Expected Results:  
Should display the time as 12:11PM instead of 0:11AM.

The output of "lsb_release -a" : http://pastebin.kde.org/p4v5s1srq

The output of "uname -a" : http://pastebin.kde.org/pcncndtwb
Comment 1 R.Harish Navnit 2014-01-18 10:03:55 UTC
I would like to have this bug assigned to me and attempt a fix . Thank you.
Comment 2 Sinny Kumari 2014-01-18 19:08:04 UTC
Thanks for noticing this issue. Good catch!
Assigned to Hraish as per his request.
Comment 3 heenamahour 2014-02-11 09:20:04 UTC
Created attachment 85099 [details]
Using time data engine solves this issue too .

Using Locale and by time data engine , now it will display the locale timings without seconds as required .
Comment 4 Shantanu Tushar 2014-03-12 15:30:32 UTC
This is fixed by http://commits.kde.org/plasma-mediacenter/a237d0fb4aba0052e0c7232e42a311b4867a8368

Please verify and close bug report accordingly.
Comment 5 Ashish Madeti 2014-03-15 08:18:48 UTC
The following patch by Heena Mahour, solved the issue :
https://git.reviewboard.kde.org/r/114429/