Bug 329193 - Color selector docker's zoom-on-hover forbids from clicking on many other buttons
Summary: Color selector docker's zoom-on-hover forbids from clicking on many other but...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Color Selectors (show other bugs)
Version: 2.8 Beta
Platform: Microsoft Windows Microsoft Windows
: NOR minor
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-24 12:33 UTC by Michel T Gonzalez
Modified: 2013-12-28 14:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel T Gonzalez 2013-12-24 12:33:24 UTC
In the Color selector settings, when the Zoom selector setting is set to "on mouse over", hovering over the color selector docker will make the zoomed-in selector show up, as expected. But this will prevent from clicking other buttons entirely, such as the Color selector settings, but also buttons like Maximise/Restore window.

When Krita hides the zoomed-in selector after a brief delay, all things are clickable as usual.

The selector settings can still be accessed from the Configure krita menu normally.
Comment 1 Dmitry Kazakov 2013-12-25 11:19:01 UTC
Confirmed!
Comment 2 Dmitry Kazakov 2013-12-26 12:29:06 UTC
Git commit 1f4db6b868730ba8883c9a9d1756bd9d8e91bf4d by Dmitry Kazakov.
Committed on 26/12/2013 at 12:27.
Pushed by dkazakov into branch 'master'.

Make the Color Selector Color Preview widget a ToolTip widget

Any PopUp window is a modal which is not what we want, because then
no other widget will get the events. Previously, the problem was solved
by explicitly forwarding events to the parent.

M  +10   -8    krita/plugins/extensions/dockers/advancedcolorselector/kis_color_selector.cpp
M  +67   -98   krita/plugins/extensions/dockers/advancedcolorselector/kis_color_selector_base.cpp
M  +5    -4    krita/plugins/extensions/dockers/advancedcolorselector/kis_color_selector_base.h

http://commits.kde.org/calligra/1f4db6b868730ba8883c9a9d1756bd9d8e91bf4d
Comment 3 Dmitry Kazakov 2013-12-28 14:59:04 UTC
Git commit e9460b79cd705d116a8f2937d6fdf11d40190d9c by Dmitry Kazakov.
Committed on 26/12/2013 at 12:27.
Pushed by dkazakov into branch 'calligra/2.8'.

Make the Color Selector Color Preview widget a ToolTip widget

Any PopUp window is a modal which is not what we want, because then
no other widget will get the events. Previously, the problem was solved
by explicitly forwarding events to the parent.

M  +10   -8    krita/plugins/extensions/dockers/advancedcolorselector/kis_color_selector.cpp
M  +67   -98   krita/plugins/extensions/dockers/advancedcolorselector/kis_color_selector_base.cpp
M  +5    -4    krita/plugins/extensions/dockers/advancedcolorselector/kis_color_selector_base.h

http://commits.kde.org/calligra/e9460b79cd705d116a8f2937d6fdf11d40190d9c