Bug 329160 - Undo is broken when 'merge with layer below' on 2 groups with several layers
Summary: Undo is broken when 'merge with layer below' on 2 groups with several layers
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Layer Stack (show other bugs)
Version: 2.8 Beta
Platform: unspecified Other
: NOR critical
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords: release_blocker
Depends on:
Blocks:
 
Reported: 2013-12-23 15:34 UTC by Bollebib
Modified: 2013-12-28 14:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bollebib 2013-12-23 15:34:02 UTC
copied from IRC


16:25:26 - Bollebib2: if you merge 2 groups with the command 'merge with layer below" it does go as expected ,but when you undo that,the undo is broken
16:25:42 - Bollebib2: so be careful trying this on unsaved work
16:26:22 - boud: let me check
16:26:40 - boud: after a rebuild...
16:29:13 - deevad: Bollebib2:  Oh, I see Bollebib2, I could reproduce. I don't get a crash , but missing layers when undoing ; each group remind only 1 top layer as far as I observed 
16:29:27 - boud: I consider that confirmation...
16:29:28 - Bollebib2: yeah
16:29:34 - boud: high-priority bug then
16:29:47 - boud: release blocker even since it's dataloss
16:29:59 - Bollebib2: do I make a bug of this?
16:30:00 - deevad: yes, it can be painfull ^ ^
16:30:05 - boud: yes, please

Reproducible: Always
Comment 1 Halla Rempt 2013-12-23 15:35:49 UTC
Confirmed by deevad
Comment 2 Dmitry Kazakov 2013-12-24 09:56:32 UTC
Git commit 83e4659754d07df2fb8e41c69a014ca73ad91b0c by Dmitry Kazakov.
Committed on 24/12/2013 at 09:56.
Pushed by dkazakov into branch 'master'.

Fix undo of Merge Down command

M  +7    -2    krita/image/commands/kis_image_layer_remove_command.cpp

http://commits.kde.org/calligra/83e4659754d07df2fb8e41c69a014ca73ad91b0c
Comment 3 Dmitry Kazakov 2013-12-28 14:58:06 UTC
Git commit b75e1e26b7cd369f4a5e3f1fe57a6d3138cd6d36 by Dmitry Kazakov.
Committed on 24/12/2013 at 09:56.
Pushed by dkazakov into branch 'calligra/2.8'.

Fix undo of Merge Down command

M  +7    -2    krita/image/commands/kis_image_layer_remove_command.cpp

http://commits.kde.org/calligra/b75e1e26b7cd369f4a5e3f1fe57a6d3138cd6d36