Bug 328737 - Multiselection should disable showing mark for install/remove button
Summary: Multiselection should disable showing mark for install/remove button
Status: RESOLVED FIXED
Alias: None
Product: muon
Classification: Unclassified
Component: muon (show other bugs)
Version: 2.1.2
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Volkan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-12 22:07 UTC by Volkan
Modified: 2013-12-23 14:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volkan 2013-12-12 22:07:32 UTC
Currently, when multiple items are selected, muon still suggests marking for installation on DetailWindow. Clicking on it only installs the first one selected.

Reproducible: Always

Steps to Reproduce:
1. Open muon
2. Select multiple packages to install by pressing Control key
3. Click "mark for: 'install'" button on the bottom of the screen
Actual Results:  
It marks only the first one even though multiple packages are selected.

Expected Results:  
It should disable this pane to prevent confusion.

Probably hiding bottom pane should solve the issue.
Comment 1 Volkan 2013-12-23 14:53:37 UTC
Git commit 16bab0472cbfc346814835ffb0a640eea8bbd88b by Volkan Gezer.
Committed on 23/12/2013 at 14:50.
Pushed by vgezer into branch 'master'.

Fix two bugs regarding to multiple selection

This patch should solve issues related to multiple selection:
Solves right click issue when only one item status has changed and
disables install/remove button on DetailsWidget when multiple selection
is made since this button only installs one of the selections and causes
confusions.
Related: bug 327366, bug 327366
CCMAIL: volkangezer@gmail.com
REVIEW: 114630

M  +1    -1    CMakeLists.txt
M  +15   -3    muon/DetailsTabs/MainTab.cpp
M  +2    -0    muon/DetailsTabs/MainTab.h
M  +7    -0    muon/DetailsWidget.cpp
M  +2    -0    muon/DetailsWidget.h
M  +5    -0    muon/PackageModel/PackageView.cpp
M  +1    -0    muon/PackageModel/PackageView.h
M  +26   -5    muon/PackageModel/PackageWidget.cpp

http://commits.kde.org/muon/16bab0472cbfc346814835ffb0a640eea8bbd88b
Comment 2 Volkan 2013-12-23 14:53:37 UTC
Git commit 16bab0472cbfc346814835ffb0a640eea8bbd88b by Volkan Gezer.
Committed on 23/12/2013 at 14:50.
Pushed by vgezer into branch 'master'.

Fix two bugs regarding to multiple selection

This patch should solve issues related to multiple selection:
Solves right click issue when only one item status has changed and
disables install/remove button on DetailsWidget when multiple selection
is made since this button only installs one of the selections and causes
confusions.
Related: bug 327366, bug 327366
CCMAIL: volkangezer@gmail.com
REVIEW: 114630

M  +1    -1    CMakeLists.txt
M  +15   -3    muon/DetailsTabs/MainTab.cpp
M  +2    -0    muon/DetailsTabs/MainTab.h
M  +7    -0    muon/DetailsWidget.cpp
M  +2    -0    muon/DetailsWidget.h
M  +5    -0    muon/PackageModel/PackageView.cpp
M  +1    -0    muon/PackageModel/PackageView.h
M  +26   -5    muon/PackageModel/PackageWidget.cpp

http://commits.kde.org/muon/16bab0472cbfc346814835ffb0a640eea8bbd88b