Bug 327920 - special keys (delete, [, }, etc.) broken
Summary: special keys (delete, [, }, etc.) broken
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: Vi Input Mode (show other bugs)
Version: 3.11.90
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-21 21:41 UTC by Martin Sandsmark
Modified: 2013-12-04 13:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Sandsmark 2013-11-21 21:41:10 UTC
I can't input special keys like delete, [ or } in a katepart with vim mode enabled.

It seems to be a recent regression.

Reproducible: Always
Comment 1 Michal Humpula 2013-11-29 17:33:36 UTC
Hi Martin, thanks for report! I can confirm the problem with Del key in insert mode on KDE/4.12 branch.

After bisection this looks like the commit that changed the behaviour: http://quickgit.kde.org/?p=kate.git&a=commit&h=1dd5ed8

Current devel branch doesn't show the problem behaviour. Is it possible for you to confirm that on devel (master) version everything works for you?
Comment 2 Michal Humpula 2013-12-04 13:40:24 UTC
Git commit f759aadb4070752eebc3e523d729fee48e71d525 by Michal Humpula.
Committed on 29/11/2013 at 17:52.
Pushed by michalhumpula into branch 'KDE/4.12'.

vi-mode: fix unfunctional Del key

regression on KDE/4.12 branch
REVIEW: 114210

M  +1    -1    part/vimode/katevikeyparser.cpp

http://commits.kde.org/kate/f759aadb4070752eebc3e523d729fee48e71d525