Bug 326053 - Oxygen Transparent crashes amarok
Summary: Oxygen Transparent crashes amarok
Status: RESOLVED FIXED
Alias: None
Product: Oxygen
Classification: Plasma
Component: style (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-15 15:25 UTC by Yichao Yu
Modified: 2013-10-18 07:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yichao Yu 2013-10-15 15:25:04 UTC
I'm not really sure if this the right place for this since this issue affects all (released) qt4 styles which supports translucency (AFAIK, QtCurve, Oxygen-Transparent, Bespin) and what I have found is just a workaround.

The problem seems to be that there is a QGLWidget (Analyser::Base2D) in the amarok that when not being set to TranslucentBackground while other's ones are crashes in mesa on drawing. However, a simple program with a QGLWidget does not have the same problem so I'm still not sure yet what exactly is the cause of this.

I am not really familiar with OpenGL but I think this is probably a good start for fixing this problem (and this is why I report this issue here). The workaround I am using now can be found here[1], which is setting background translucency for all QGLWidget and I haven't found any regression after doing this yet.

Screenshot of the widget which causes the problem (top part, not sure what it is called...) as well as a translucent amarok with that widget.

[1] https://github.com/QtCurve/qtcurve/commit/e353f35b2c0453063adeda09d5c44e79ebd20147
[2] http://wstaw.org/m/2013/10/15/plasma-desktopwXp442.png


Reproducible: Always
Comment 1 Hugo Pereira Da Costa 2013-10-18 07:32:37 UTC
Git commit 6fdd219c293d8159167604a45cf233459d2be2f6 by Hugo Pereira Da Costa.
Committed on 18/10/2013 at 07:31.
Pushed by hpereiradacosta into branch 'KDE/4.11'.

set WA_TRANSLUCENT_BACKGROUND on QGLWidgets.

M  +4    -0    style/oxygenstyle.cpp

http://commits.kde.org/oxygen-transparent/6fdd219c293d8159167604a45cf233459d2be2f6
Comment 2 Hugo Pereira Da Costa 2013-10-18 07:33:21 UTC
Confirmed crash and fix.
Pushed change,
so closing.
Many thanks ! 

Hugo