Bug 325543 - Make hit area for expanding/collapsing folders bigger
Summary: Make hit area for expanding/collapsing folders bigger
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: view-engine: details mode (show other bugs)
Version: 4.11.1
Platform: unspecified Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-02 11:54 UTC by Kai Uwe Broulik
Modified: 2013-10-09 17:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.12


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2013-10-02 11:54:00 UTC
In details mode it is really hard hitting the little triangles to expand/collapse folders. You really have to hit the icon, clicking the huge space left or right of it, or slightly above, will not do.

Reproducible: Always

Steps to Reproduce:
1. Go to a folder with subfolders
2. Switch to details view
3. Click slightly outside the expanding/collapse triangle
Actual Results:  
Nothing happens

Expected Results:  
Expand/Collapse folder, even if you not exactly hit the triangle itself.
Comment 1 Christoph Feck 2013-10-02 20:24:38 UTC
Cannot reproduce. Here the complete rectangle to the left of the folder icon is clickable. Tested with Oxygen and Skulpture style.
Comment 2 Christoph Feck 2013-10-02 20:26:06 UTC
Ah, wait, with nested folders, the inset rectangles could indeed be enlarged, up to the border of the view.
Comment 3 Christoph Feck 2013-10-02 20:29:04 UTC
(Which is a regression compared to "normal" QTreeView, so actually a little bug :)
Comment 4 Christoph Feck 2013-10-02 20:33:39 UTC
Hm, no, for a normal QTreeView, you actually have to double-click, if you are too far outside. Sorry for the flood.
Comment 5 Christoph Feck 2013-10-02 20:41:53 UTC
Part of the problem is the missing hover-feedback. With QTreeView, Oxygen style highlights the arrows when hovering them.
Comment 6 Frank Reininghaus 2013-10-04 08:40:42 UTC
I guess another part of the problem is that the clickable area is always (KIconLoader::SizeSmall)^2, no matter what icon size the user chooses in Details View.

@Kai: am I assuming correctly that this is the most important aspect of your report?
Comment 7 Kai Uwe Broulik 2013-10-04 08:49:31 UTC
Exactly :-)
Comment 8 Emmanuel Pescosta 2013-10-09 17:56:08 UTC
Git commit 4873685ebd383de37bb16bfa70d266bacc9a7b11 by Emmanuel Pescosta.
Committed on 09/10/2013 at 17:52.
Pushed by emmanuelp into branch 'master'.

Use the icon size from KItemListStyleOption for the width and height of the
expansion area instead of KIconLoad::SizeSmall.
REVIEW: 113169
FIXED-IN: 4.12

M  +3    -2    dolphin/src/kitemviews/kstandarditemlistwidget.cpp

http://commits.kde.org/kde-baseapps/4873685ebd383de37bb16bfa70d266bacc9a7b11