Bug 325465 - Create todo dialogue duplicates itlself after hitting 'apply' when creating seperate todos in quick sucession
Summary: Create todo dialogue duplicates itlself after hitting 'apply' when creating s...
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: todoview (show other bugs)
Version: 4.11.1
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 325583 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-30 16:01 UTC by tprotopopescu
Modified: 2013-10-08 16:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tprotopopescu 2013-09-30 16:01:12 UTC
When creating seperate tasks one after the other, hitting `apply' in the task details dialogue window creates duplicate windows. First task does not create a duplicate. Second task creates one duplicate (for a total of two instances of the dialogue window with the same title bar heading and one with <2>). Third task creates two duplicates (total of three with <2> and <3> in the title). And so on. Sometime the duplicates have only the 'general' properties tab, in the bottom half of the dialogue window. Sometimes all tabs appear. 

If you create one task and wait a while, 10 to 20 minutes, to create another there are no duplicates, this seems to happen only if you create the tasks right after each other. 

Reproducible: Always

Steps to Reproduce:
1. Create a task, hit `apply' and then 'ok' 
2. Create another task hit `apply'. 
3. You should have two instances of the task details dialogue window, with the same title and one with <2>.
4. Hit `ok' (or 'cancel') on both. 
5. Create new task, hit `apply'.
6. You should have three instances of the task details dialogue window, with the same title and one with <2> and one with <3>.
7. Repeat - each repetition should create one extra duplicate dialogue window: the n-th created task should have n instances of the dialogue window, all with the same title and each with <n>, <n-1>, <n-2> and so on.
Actual Results:  
When creating a series of todos the n-th task in the series will have n instances of the task details dialogue window, after pressing 'apply' on the initial window. 

Expected Results:  
Hitting `apply' should create the task and leave only the open instance open, do duplicates should be created. 

This only happens when creating todos immediately one after the other. If you wait some time between creating tasks (10 - 20 minutes) this behaviour does not occur, only one instance of the dialogue is open.
Comment 1 Sergio Martins 2013-10-02 09:28:52 UTC
How do you create the new to-do ? There are 5 or 6 different ways to do so.

I've seen this problem but I can't reproduce it now
Comment 2 tprotopopescu 2013-10-02 13:55:19 UTC
I use the right-click menu. None of the main toolbar button, the option in the main menu, or the keyboard short-cut produce this. But after creating a couple of todos via these other ways, creating one through the right-click menu creates duplicates depending on the number of non-duplicate generating todos you have just created.
Comment 3 Sergio Martins 2013-10-08 16:07:01 UTC
*** Bug 325583 has been marked as a duplicate of this bug. ***
Comment 4 Sergio Martins 2013-10-08 16:09:02 UTC
Git commit 15c869736482640bf9f4da69072ece1bda799932 by Sergio Martins.
Committed on 08/10/2013 at 16:01.
Pushed by smartins into branch 'KDE/4.11'.

Don't forget to accept the close event after KDialog::reject().

If we simply ignore the close event, Qt::WA_DeleteOnClose won't
have any effect and the dialog just gets hidden.

M  +4    -1    incidenceeditor-ng/incidencedialog.cpp

http://commits.kde.org/kdepim/15c869736482640bf9f4da69072ece1bda799932