Bug 325117 - Event dissociated from recurrence (and imported again) won't show in calendar
Summary: Event dissociated from recurrence (and imported again) won't show in calendar
Status: RESOLVED UNMAINTAINED
Alias: None
Product: korganizer
Classification: Unclassified
Component: recurrence (show other bugs)
Version: GIT (master)
Platform: Ubuntu Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-20 09:56 UTC by Alexey Brodkin
Modified: 2017-01-07 21:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Brodkin 2013-09-20 09:56:20 UTC
On attempt to import specific .ics file (see detail below) nothing appears in KOrganizer calendar GUI even though there's an assuring message from KOrganizer "The calendar item from file:///home/.../cal.ics was successfully imported."

But event is seen in Akonadiconsole.

It could be something similar as #282591 but main point of this bug is a bit different - thus filing a separate bug-report.

Reproducible: Always

Steps to Reproduce:
1. In KOrganizer create a recurring event in "Personal calendar"
2. Dissociate any event from recurrence
3. Right-click -> "Send as iCalendar" on dissociated event. 

This will be the file sent ("cal.ics"):
=========
BEGIN:VCALENDAR
PRODID:-//K Desktop Environment//NONSGML libkcal 4.3//EN
VERSION:2.0
X-KDE-ICAL-IMPLEMENTATION-VERSION:1.0
BEGIN:VEVENT
ORGANIZER;CN="Me":MAILTO:me@me.com
DTSTAMP:20130920T093504Z
CREATED:20130920T093455Z
UID:0fece2eb-c862-4ab4-8066-353aa8e8ac49
SEQUENCE:2
LAST-MODIFIED:20130920T093504Z
SUMMARY:Test event 1
RECURRENCE-ID:20130920T200000Z
DTSTART:20130920T200000Z
DTEND:20130920T210000Z
TRANSP:TRANSPARENT
END:VEVENT
END:VCALENDAR
=========

4. Import in KOrganizer and it won't appear in calendar. But thi event is displayed in "aconadiconsole".
Actual Results:  
No event appears in calendar.

Expected Results:  
Imported even to appear in calendar.
Comment 1 Alexey Brodkin 2013-09-20 10:05:04 UTC
The same event could be easily imported in Mozilla Lightning and there it will be correctly displayed in calendar.
Comment 2 Sergio Martins 2013-09-20 10:58:04 UTC
Korganizer should strip RECURRENCE-ID before sending it. It doesn't make sense to have a single occurrence with RECURRENCE-ID and no main recurring incidence info.

Mozilla lightning is being a bit more loose here.
IMO, korganizer is doing great by not displaying it but doing a bad job at exporting it.
Comment 3 Alexey Brodkin 2013-09-20 11:08:25 UTC
Completely agree with this point - no reason to have RECURRENCE-ID in single event.
But I came to the test case described above when I noticed many events from MS Exchange (accessed via DavMail -> CalDav) missing from KOrganizer. Then I sent a couple of events right from my MS Outlook to myself and examined attached .ics files. They were exactly the same, i.e. this behavior is not because of DavMail involvement.

In other words from what I see this kind of events is very likely to happen when people deal with MS Exchange servers so IMHO would be nice to act as Mozilla guys do - display single events even though they have RECURRENCE-ID.

BTW single event is just a corner-case of recurring even - it recurs N=1 times.
Comment 4 Sergio Martins 2013-09-20 17:39:39 UTC
Git commit d75e3a686a5009a4c67914e56cfb7b0d8cad82c6 by Sergio Martins.
Committed on 20/09/2013 at 17:34.
Pushed by smartins into branch 'KDE/4.11'.

Strip out RECURRENCE-ID before sending single occurrence as ical.

RECURRENCE-ID incidences only make sense when the master incidence
is present (the one that contains the whole recurring series).

Leaving this bug open still, as we can make korganizer tolerate
and show these orphan incidences that don't have the corresponding
master incidence available.

M  +11   -3    akonadi/calendar/itiphandler.cpp

http://commits.kde.org/kdepimlibs/d75e3a686a5009a4c67914e56cfb7b0d8cad82c6
Comment 5 Alexey Brodkin 2013-09-20 17:44:58 UTC
Thanks! I will try this particular change as soon as packages get built.
As for tolerance to orphan incidences, what are next steps?
I mean may I be of any help here?
Comment 6 Denis Kurz 2016-09-24 18:54:30 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of korganizer (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 7 Denis Kurz 2017-01-07 21:57:43 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.