Bug 325060 - up navigation not working if pressed
Summary: up navigation not working if pressed
Status: RESOLVED FIXED
Alias: None
Product: kdeconnect
Classification: Unclassified
Component: android-application (show other bugs)
Version: unspecified
Platform: Android Android 4.x
: NOR minor (vote)
Target Milestone: ---
Assignee: Albert Vaca
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-18 14:40 UTC by Mauro Panzeri
Modified: 2013-09-24 13:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mauro Panzeri 2013-09-18 14:40:00 UTC
app version: 0.2.1

Reproducible: Always

Steps to Reproduce:
1. open the kde-connect android app
2. select a connected device 
3. press the up navigation button in the actionbar
Actual Results:  
previous activity is not shown

Expected Results:  
return to the previous screen
Comment 1 Albert Vaca 2013-09-18 15:32:16 UTC
Git commit b1ca8757c67aaa36922b13c5995933c355f22304 by Albert Vaca.
Committed on 18/09/2013 at 15:27.
Pushed by albertvaka into branch 'master'.

Parent activities where not correctly set

M  +33   -32   KdeConnect/src/main/AndroidManifest.xml

http://commits.kde.org/kdeconnect-android/b1ca8757c67aaa36922b13c5995933c355f22304
Comment 2 Albert Vaca 2013-09-18 15:33:28 UTC
I fixed it in the master branch, but I won't update the app in the Play Store until next week because I want to include some new features in the update too. Thanks for the report.
Comment 3 Albert Vaca 2013-09-24 13:04:31 UTC
Git commit 8800c4503cf995d7dc658c64db99ef71b2f18e6f by Albert Vaca.
Committed on 18/09/2013 at 15:27.
Pushed by albertvaka into branch 'filetransfer'.

Parent activities where not correctly set

M  +33   -32   KdeConnect/src/main/AndroidManifest.xml

http://commits.kde.org/kdeconnect-android/8800c4503cf995d7dc658c64db99ef71b2f18e6f