Bug 324989 - PSD Exporter breaks file
Summary: PSD Exporter breaks file
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: File formats (show other bugs)
Version: git master (please specify the git hash!)
Platform: unspecified Linux
: NOR major
Target Milestone: ---
Assignee: Siddharth
URL:
Keywords:
: 313300 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-17 10:10 UTC by Paul Geraskin
Modified: 2014-01-01 13:38 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Geraskin 2013-09-17 10:10:33 UTC
Hi devs.

If i paint behind the canvas on the default layer, then save to PSD. So PSD will be broken.

See screen:
http://i.imgur.com/VwdRxeZ.png

Talk to DmitryK on IRC:
<mifth> dmitryK: PSD is broken if you paint behind the canvas size. Use only one layer.
<dmitryK> mifth: we need Siddharth Sharma for that :)
<mifth> dmitryK: should i create a new report?
<dmitryK> mifth: yes, you'd better create one
<mifth> dmitryK: are you sure this bug in master too? I use your branch
<dmitryK> mifth: yes, I've checked in the sahil_'s branch, which is also based on master and the bug persists.
Comment 1 Halla Rempt 2013-09-28 12:48:29 UTC
*** Bug 313300 has been marked as a duplicate of this bug. ***
Comment 2 Halla Rempt 2014-01-01 13:38:11 UTC
Git commit d6070232c6ccccc6995390755c9d2688e838498a by Boudewijn Rempt.
Committed on 01/01/2014 at 13:37.
Pushed by rempt into branch 'calligra/2.8'.

PSD: fix saving a single layer image where the layer is larger than the image

The background layer in photoshop cannot be larger than the image itself.

M  +1    -1    krita/plugins/formats/psd/psd_image_data.cpp

http://commits.kde.org/calligra/d6070232c6ccccc6995390755c9d2688e838498a
Comment 3 Halla Rempt 2014-01-01 13:38:20 UTC
Git commit 7f9ecfed3728aecc54e33a53d8ca94d34e84088c by Boudewijn Rempt.
Committed on 01/01/2014 at 13:37.
Pushed by rempt into branch 'master'.

PSD: fix saving a single layer image where the layer is larger than the image

The background layer in photoshop cannot be larger than the image itself.

M  +1    -1    krita/plugins/formats/psd/psd_image_data.cpp

http://commits.kde.org/calligra/7f9ecfed3728aecc54e33a53d8ca94d34e84088c