Bug 324574 - Application specific icon now doesn't work
Summary: Application specific icon now doesn't work
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kdeui (show other bugs)
Version: 4.11.1
Platform: Chakra Linux
: NOR critical with 81 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords: regression, reproducible
: 324599 324676 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-05 21:05 UTC by Weng Xuetian
Modified: 2013-10-09 00:43 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Weng Xuetian 2013-09-05 21:05:30 UTC
Application like Quassel / KDevelop which depends on icon under (irc-channel-active, dirsync)

/usr/share/apps/<app name>/icons doesn't work anymore, strace shows that icon under that folder doesn't load at all. (path depends on prefix)

I have another machine with KDE 4.11.0 which seems ok.

Reproducible: Always

Steps to Reproduce:
strace quassel 2>&1 | grep '/usr/share/apps/quassel/icons'

Actual Results:  
no icon is loaded under this path

Expected Results:  
it should load icon with such path
Comment 1 Christoph Feck 2013-09-05 21:48:15 UTC
It also affects Kolourpaint, making its toolbox unusable. Let's see if I can find the commit that broke it.
Comment 2 Jekyll Wu 2013-09-06 23:12:01 UTC
*** Bug 324599 has been marked as a duplicate of this bug. ***
Comment 3 carasin 2013-09-07 08:23:42 UTC
I confirm it. I have this issue with kolourpaint and krusader.
Comment 4 Luca Giambonini 2013-09-08 19:36:48 UTC
Exact same problem here with the calligra suite. With kde version 4.11.0 no problem, but after the update to 4.11.1 this issue arise.
I confirm the issue on kolourpaint too.
Comment 5 Christoph Feck 2013-09-08 21:22:33 UTC
*** Bug 324676 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Feck 2013-09-08 21:28:36 UTC
David, I have no idea which commit in 4.11.1 could affect icon loading, maybe it is related to the sycoca change to fix MIME handling?
Comment 7 Christoph Feck 2013-09-08 21:30:58 UTC
(See also regressions at bug 324502 and bug 324651 which could also be caused by the same commits)
Comment 8 Aljaž Kolšek 2013-09-08 22:07:40 UTC
I confirm this problem with Krita 2.7.1
Comment 9 Aristide 2013-09-08 22:21:28 UTC
I confirm problem with many icons in Digikam
Comment 10 Hrvoje Senjan 2013-09-08 23:34:44 UTC
(In reply to comment #6)
> David, I have no idea which commit in 4.11.1 could affect icon loading,
> maybe it is related to the sycoca change to fix MIME handling?

I've tried reverting that commit, with the same result - no icons...
Comment 11 Martin Koller 2013-09-09 09:19:48 UTC
raising to critical as it renders at least kolourpaint useless
Comment 12 Weng Xuetian 2013-09-09 12:30:21 UTC
Commit that cause this bug:

http://commits.kde.org/kde-workspace/e74a264325e8af834d800ee650c4bf208e1b2fb1

KIconLoader requires KApplication constructed to get the correct application name and mainComponent, while the plugin is loaded before KApplication construct finishes.
Comment 13 Weng Xuetian 2013-09-09 12:48:07 UTC
I just proposed a patch.
https://git.reviewboard.kde.org/r/112602/
Comment 14 Weng Xuetian 2013-09-09 15:46:42 UTC
Git commit 2e5a2450762f8dedf9ffd77028ed06b3a39a807d by Weng Xuetian.
Committed on 09/09/2013 at 15:43.
Pushed by xuetianweng into branch 'KDE/4.11'.

Delay KDE class initialization to main loop

Gui platform plugin is loaded during QApplication construction, but it
relies on some KApplication/QApplication data to work correctly.

This patch delays the initialization to main loop, to ensure
KApplication/QApplication is already constructed.
FIXED-IN: 4.11.2
REVIEW: 112602

M  +9    -3    qguiplatformplugin_kde/qguiplatformplugin_kde.cpp

http://commits.kde.org/kde-workspace/2e5a2450762f8dedf9ffd77028ed06b3a39a807d
Comment 15 carasin 2013-09-09 18:12:40 UTC
I confirm that this patch fixes the issue. Thanks.
Comment 16 Jekyll Wu 2013-10-09 00:43:25 UTC
*** Bug 325786 has been marked as a duplicate of this bug. ***