Bug 324466 - Redraw glitch when label of a taskbar item changes
Summary: Redraw glitch when label of a taskbar item changes
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-taskbar (show other bugs)
Version: 4.11.0
Platform: Gentoo Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-03 16:21 UTC by Frank Steinmetzger
Modified: 2018-06-08 18:58 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Steinmetzger 2013-09-03 16:21:46 UTC
When the text of a taskbar item changes, my taskbar has leftover pixels from the previous label’s decenders. This may happen e.g. when switching tabs or view locations in browsers or file managers.

If the item contains text with descenders, such as “Desktop - Dolphin”, and then changes, the bottommost pixels of the “p” remain visible below the new text. Those will be cleared once I move the mouse over the item.

Usually I use the “Klassik” plasma theme (http://opendesktop.org/content/show.php?content=117677), but I was able to reproduce the issue with the “Air” theme as well. My fonts are pretty much standard stuff – all are set to DejaVu Sans 8pt.

Reproducible: Always

Actual Results:  
The taskbar item should be completely cleared upon text change.
Comment 1 Christoph Feck 2013-09-03 17:24:14 UTC
My fault, I missed the place where the label is erased. Will look into it.
Comment 2 Christoph Feck 2013-09-03 20:15:53 UTC
Git commit b3fce9ca615bfa33304bf1e18a61225e1eaccb17 by Christoph Feck.
Committed on 03/09/2013 at 20:13.
Pushed by cfeck into branch 'KDE/4.11'.

Erase text outside boundingRect when text changes
FIXED-IN: 4.11.2
Ack'ed by Eike Hein

M  +1    -1    plasma/desktop/applets/tasks/support/textlabel.cpp

http://commits.kde.org/kde-workspace/b3fce9ca615bfa33304bf1e18a61225e1eaccb17
Comment 3 Frank Steinmetzger 2013-12-27 13:08:13 UTC
Sorry to disappoint you. I don't seem to have received the fix, neither in 4.11.2 nor in 4.12, which I've been running since 2 days ago.
Comment 4 Nate Graham 2018-06-08 18:58:37 UTC
Hello!

This bug report was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this bug is already resolved in Plasma 5.

Accordingly, we hope you understand why we must close this bug report. If the issue described  here is still present in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham