Bug 324385 - KRemoteControl crashes after adding a new remotemode
Summary: KRemoteControl crashes after adding a new remotemode
Status: RESOLVED FIXED
Alias: None
Product: kremotecontrol
Classification: Unclassified
Component: settings (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michael Zanetti
URL:
Keywords: drkonqi
: 324450 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-02 09:26 UTC by petesnew
Modified: 2013-09-03 12:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description petesnew 2013-09-02 09:26:00 UTC
Application: kcmshell4 (4.11.00)
KDE Platform Version: 4.11.00
Qt Version: 4.8.5
Operating System: Linux 3.7.10-1.16-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- A first mode was created succesfully
- Adding a second mode filling out the dialog crashes KRemoteControl after clicking the [OK] button.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE-Kontrollmodul (kcmshell4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  length (this=0x10) at ../../src/corelib/tools/qstring.h:697
#7  QtPrivate::QStringList_contains (that=0x7fff34cf00b0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x00007f174aabcd55 in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff34cf00b0) at /usr/include/QtCore/qstringlist.h:174
#9  Remote::isAvailable (this=0x0) at /usr/src/debug/kremotecontrol-4.11.0/libkremotecontrol/remote.cpp:356
#10 0x00007f174ad2ec69 in KCMRemoteControl::actionSelectionChanged (this=0x1353160, index=...) at /usr/src/debug/kremotecontrol-4.11.0/kcmremotecontrol/kcmremotecontrol.cpp:373
#11 0x00007f1764c7d44f in QMetaObject::activate (sender=0x10e24c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff34cf0240) at kernel/qobject.cpp:3556
#12 0x00007f176434f36a in QItemSelectionModel::currentChanged (this=this@entry=0x10e24c0, _t1=..., _t2=...) at .moc/release-shared/moc_qitemselectionmodel.cpp:172
#13 0x00007f176434f459 in QItemSelectionModel::setCurrentIndex (this=0x10e24c0, index=..., command=...) at itemviews/qitemselectionmodel.cpp:1175
#14 0x00007f17642f945e in QAbstractItemView::focusInEvent (this=0x1408980, event=0x7fff34cf0bc0) at itemviews/qabstractitemview.cpp:2126
#15 0x00007f1763e440b9 in QWidget::event (this=0x1408980, event=0x7fff34cf0bc0) at kernel/qwidget.cpp:8496
#16 0x00007f17641efa16 in QFrame::event (this=0x1408980, e=0x7fff34cf0bc0) at widgets/qframe.cpp:557
#17 0x00007f176426faeb in QAbstractScrollArea::event (this=0x1408980, e=0x7fff34cf0bc0) at widgets/qabstractscrollarea.cpp:996
#18 0x00007f1764304efb in QAbstractItemView::event (this=0x1408980, event=0x7fff34cf0bc0) at itemviews/qabstractitemview.cpp:1580
#19 0x00007f1763df492c in QApplicationPrivate::notify_helper (this=this@entry=0xedf3a0, receiver=receiver@entry=0x1408980, e=e@entry=0x7fff34cf0bc0) at kernel/qapplication.cpp:4562
#20 0x00007f1763df8dab in QApplication::notify (this=0x7fff34cf1980, receiver=0x1408980, e=0x7fff34cf0bc0) at kernel/qapplication.cpp:4423
#21 0x00007f1765a07f76 in KApplication::notify (this=0x7fff34cf1980, receiver=0x1408980, event=0x7fff34cf0bc0) at /usr/src/debug/kdelibs-4.11.0/kdeui/kernel/kapplication.cpp:311
#22 0x00007f1764c67f3e in QCoreApplication::notifyInternal (this=0x7fff34cf1980, receiver=0x1408980, event=0x7fff34cf0bc0) at kernel/qcoreapplication.cpp:949
#23 0x00007f1763df353e in sendEvent (event=0x7fff34cf0bc0, receiver=0x1408980) at ../../src/corelib/kernel/qcoreapplication.h:231
#24 QApplicationPrivate::setFocusWidget (focus=0x1408980, reason=Qt::ActiveWindowFocusReason) at kernel/qapplication.cpp:2278
#25 0x00007f1763e3795b in QWidget::setFocus (this=0x1408980, reason=Qt::ActiveWindowFocusReason) at kernel/qwidget.cpp:6464
#26 0x00007f1763df8ad0 in QApplication::setActiveWindow (act=<optimized out>) at kernel/qapplication.cpp:2672
#27 0x00007f1763e6ef5d in QApplication::x11ProcessEvent (this=0x7fff34cf1980, event=0x7fff34cf12e0) at kernel/qapplication_x11.cpp:3570
#28 0x00007f1763e95192 in x11EventSourceDispatch (s=0xee1c70, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#29 0x00007f176058c7d5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#30 0x00007f176058cb08 in ?? () from /usr/lib64/libglib-2.0.so.0
#31 0x00007f176058cbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f1764c965b6 in QEventDispatcherGlib::processEvents (this=0xd4d790, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#33 0x00007f1763e94e0e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f1764c66bef in QEventLoop::processEvents (this=this@entry=0x7fff34cf16c0, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f1764c66e78 in QEventLoop::exec (this=0x7fff34cf16c0, flags=...) at kernel/qeventloop.cpp:204
#36 0x00007f17642a97a8 in QDialog::exec (this=0x107d1a0) at dialogs/qdialog.cpp:562
#37 0x00007f175046d31c in kdemain (_argc=15594096, _argv=<optimized out>) at /usr/src/debug/kde-runtime-4.11.0/kcmshell/main.cpp:297
#38 0x000000000040889a in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 274169.

Possible duplicates by query: bug 274169.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-09-03 12:34:19 UTC
*** Bug 324450 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2013-09-03 12:53:03 UTC
Git commit 1b1fecd8b1e290a8bbb52e249c65fbe4299c162b by Christoph Feck.
Committed on 03/09/2013 at 12:50.
Pushed by cfeck into branch 'KDE/4.11'.

Fix crash in kremotecontrol KCM

Common Qt4 porting regression: current != selected
FIXED-IN: 4.11.2

M  +16   -6    kcmremotecontrol/kcmremotecontrol.cpp
M  +2    -2    kcmremotecontrol/kcmremotecontrol.h

http://commits.kde.org/kremotecontrol/1b1fecd8b1e290a8bbb52e249c65fbe4299c162b