Bug 324263 - The "smooth" movement and rotation is too slow.
Summary: The "smooth" movement and rotation is too slow.
Status: RESOLVED FIXED
Alias: None
Product: knetwalk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Fela Winkelmolen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-30 11:28 UTC by Kunshan Wang
Modified: 2013-10-12 21:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kunshan Wang 2013-08-30 11:28:59 UTC
The recent Git commit ported KNetwalk to QtQuick.

Link to commit: http://quickgit.kde.org/?p=knetwalk.git&a=commit&h=f9aca30c11f09f12be375b301cc82604573107d2

Obvious this version makes use of the "easing" effect which makes the highlight of the current block move smoothly as the mouse moves between blocks. When I click a block, it rotates slowly at start.

But my eyes and my hand move much faster than the moving and rotation effect. I usually make four to five mouse clicks per second. I can also adjust and then lock many blocks per second. The "smooth" effect is actually annoying when I try to be fast, because I want to know very quickly where I am and what direction a block has been turned to. As my High Scores show, I can solve a "Very Hard" game in 1:04 to 1:12, which allows less than one second per block.

I suppose the behaviour of the previous KNetWalk can be retained. The highlight of the current block should instantly follow the mouse pointer. The rotation can be made faster than before rather than slower. It is preferrable that the blocks rotate fast in the beginning and slow down later rather than starting slow and stopping fast.


Reproducible: Always

Steps to Reproduce:
1. Clone the git repository, compile and run.
2. Move the mouse pointer among blocks.
3. Click a block to rotate it.
Actual Results:  
2. The highlight gradually move from one block to another.
3. It rotates slowly

Expected Results:  
2. The highlight should move instantly
3. The rotation should be fast
Comment 1 Ashwin Rajeev 2013-09-06 17:55:31 UTC
Git commit f08619ef455b3cb67f8ff74c59d8aa8e275069a9 by Ashwin Rajeev.
Committed on 06/09/2013 at 04:43.
Pushed by rajeev into branch 'ashwin'.

Fix animations

Remove animation of change in selection.
Improve rotation animation.
Cleanup the code (rename variables, use alias).

M  +2    -2    src/qml/Cable.qml
M  +3    -3    src/qml/Cell.qml
M  +7    -5    src/qml/logic.js
M  +15   -24   src/qml/main.qml

http://commits.kde.org/knetwalk/f08619ef455b3cb67f8ff74c59d8aa8e275069a9
Comment 2 Ashwin Rajeev 2013-10-05 07:12:59 UTC
Git commit 159ce0f81bbc360872b8f0700f09da15e0a14566 by Ashwin Rajeev.
Committed on 06/09/2013 at 04:43.
Pushed by rajeev into branch 'master'.

Fix animations

Remove animation of change in selection.
Improve rotation animation.
Cleanup the code (rename variables, use alias).

M  +2    -2    src/qml/Cable.qml
M  +3    -3    src/qml/Cell.qml
M  +7    -5    src/qml/logic.js
M  +15   -24   src/qml/main.qml

http://commits.kde.org/knetwalk/159ce0f81bbc360872b8f0700f09da15e0a14566
Comment 3 Christoph Feck 2013-10-12 21:00:03 UTC
Ah wait, that was actually a regression only.

Good to know we have knetwalk maintainer again, thanks Ashwin!

I will test the new version soon. As a long-time hardcore knetwalker, I will hopefully be able to provide feedback if I spot anything that could be improved.