Bug 324133 - right hand of docker panel not visible
Summary: right hand of docker panel not visible
Status: RESOLVED FIXED
Alias: None
Product: calligrawords
Classification: Unclassified
Component: usability (show other bugs)
Version: 2.7.1
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
: 326115 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-27 20:06 UTC by Geoffrey Goucher
Modified: 2013-10-18 19:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of problem (164.05 KB, image/png)
2013-08-27 20:10 UTC, Geoffrey Goucher
Details
Screenshot of problem Stroke and Fill on (177.57 KB, image/png)
2013-08-27 20:11 UTC, Geoffrey Goucher
Details
Workaround (125.68 KB, image/png)
2013-09-19 18:46 UTC, Geoffrey Goucher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Goucher 2013-08-27 20:06:45 UTC
The right side of the docker panel is cutoff and not visible. I can extend what I can see of the panel by adding the stroke and fill docker but the panel is still cutoff.

Reproducible: Always

Steps to Reproduce:
1.Open Calligra Words
2.Look 
3.
Actual Results:  
the docker panel has the right edge cutoff

Expected Results:  
The entire docker panel is visible and I can use all the icons on it.

I checked Stage and Sheets, but only Words is effected. What I get is the right panel visible to the underline button, if I add the Stroke and Fill docker it extends to background colour but it is still visibly cutoff.
Comment 1 Geoffrey Goucher 2013-08-27 20:10:12 UTC
Created attachment 81973 [details]
Screenshot of problem
Comment 2 Geoffrey Goucher 2013-08-27 20:11:31 UTC
Created attachment 81974 [details]
Screenshot of problem Stroke and Fill on
Comment 3 Camilla Boemann 2013-08-27 21:33:31 UTC
well you just need to drag the divider back towards the left,
Comment 4 Geoffrey Goucher 2013-08-30 14:55:38 UTC
Can't do that when Words is full screen and when it isn't all that does is make the document area wider; it doesn't effect the docker panel. :(
Comment 5 Geoffrey Goucher 2013-09-06 19:05:52 UTC
And nothing appears with which I drag it to the left,
Comment 6 Camilla Boemann 2013-09-06 19:30:24 UTC
the area just to the right of the scroll bar is where the divider is. it goes from top to bottom
Comment 7 Geoffrey Goucher 2013-09-10 23:51:37 UTC
Tried what you suggested but nothing come up that would let me increase the docker area.
Comment 8 Camilla Boemann 2013-09-11 10:10:22 UTC
you just click and drag

Have you never dragged a divider before in any application?
Comment 9 Geoffrey Goucher 2013-09-19 18:44:19 UTC
Yes I have. Tried what you suggested though and came up with a workaround. By clicking and dragging I managed to pop out the text editing et al bit out of the panel. This I could resize but putting it back into panel resulted in the same problem as before. 
I have enough workspace with the editing functions floating (see screenshot) to use Words now.
Comment 10 Geoffrey Goucher 2013-09-19 18:46:43 UTC
Created attachment 82413 [details]
Workaround
Comment 11 Camilla Boemann 2013-10-18 19:49:09 UTC
I guess you never managed to do it correctly.

Anyway I've just finished a change so some part can never be hidden. Not sure if it will be in a 2.7 update or only in 2.8
Comment 12 Camilla Boemann 2013-10-18 19:49:51 UTC
*** Bug 326115 has been marked as a duplicate of this bug. ***
Comment 13 Camilla Boemann 2013-10-18 19:52:35 UTC
Git commit f15209e0a3a56d73599d64281b09c6635ec1dc8b by C. Boemann.
Committed on 18/10/2013 at 19:50.
Pushed by boemann into branch 'master'.

Made it impossible for the modebox docker to be less wide than the option widget

M  +21   -2    libs/main/KoModeBox.cpp
M  +8    -0    libs/main/KoModeBox_p.h

http://commits.kde.org/calligra/f15209e0a3a56d73599d64281b09c6635ec1dc8b