Bug 324019 - moved part of image is not saved and disapear after reopen
Summary: moved part of image is not saved and disapear after reopen
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Tools (show other bugs)
Version: unspecified
Platform: Mageia RPMs Linux
: NOR major
Target Milestone: ---
Assignee: Dmitry Kazakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-25 17:30 UTC by Aleksander Szczygieł
Modified: 2013-09-03 12:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksander Szczygieł 2013-08-25 17:30:35 UTC
Selected and moved part of image was not saved, but if I did anything (i.e. draw something or click on other tool) part of image was saved.

Reproducible: Always

Steps to Reproduce:
1. Select part of image
2. Move it
3. Save image without doing anything else
4. Close Krita
5. Reopen saved image
Actual Results:  
Moved part of image disappear

Expected Results:  
Moved part of image was saved

Krita 2.6.2, Mageia 3, x86_64
Comment 1 Dmitry Kazakov 2013-08-26 18:30:36 UTC
Hi, Aleksander!

Thank you for your report! I can reproduce the bug. Looks like the stroke is not finished before saving the image.
Comment 2 Dmitry Kazakov 2013-08-26 18:40:18 UTC
Git commit 7a4a2745cd42a8ab931ec8651bbe823c7efb2c07 by Dmitry Kazakov.
Committed on 26/08/2013 at 18:39.
Pushed by dkazakov into branch 'master'.

The image should be locked when saved to Kra format

M  +3    -1    krita/ui/kis_doc2.cc

http://commits.kde.org/calligra/7a4a2745cd42a8ab931ec8651bbe823c7efb2c07
Comment 3 Dmitry Kazakov 2013-09-03 12:55:20 UTC
Git commit 857638c1c60e7574a3122d7093b461be588a3651 by Dmitry Kazakov.
Committed on 03/09/2013 at 12:53.
Pushed by dkazakov into branch 'master'.

A proper fix for the not-saved Move Tool action when it is saved while the stroke is active

This patch uses more accurate way of locking the image:

o When the autosave is happening and the document cannot lock the image,
  the document sets the autosave interval to 10s to catch the nearest
  moment when there is no stroke active

o When the usual saving is happening, the document first requests the end
  of the current stroke, then tries to lock the image again

M  +27   -0    krita/ui/kis_doc2.cc
M  +1    -0    krita/ui/kis_doc2.h

http://commits.kde.org/calligra/857638c1c60e7574a3122d7093b461be588a3651