Bug 323658 - no application icon in MS Windows for trojita.exe (patch attached)
Summary: no application icon in MS Windows for trojita.exe (patch attached)
Status: RESOLVED FIXED
Alias: None
Product: trojita
Classification: Unclassified
Component: Other (show other bugs)
Version: git
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Trojita default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-17 21:33 UTC by Christian Degenkolb
Modified: 2013-08-18 09:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
patch to add appliaction item support for MS Windows with VC2010 (4.92 KB, text/plain)
2013-08-17 21:35 UTC, Christian Degenkolb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Degenkolb 2013-08-17 21:33:47 UTC
Hi

there is no application item set for trijota.exe on MS Windows. The resulting exe gets the default icon. 

The patch fixes this for the current git in Windows with the MSVC2010 compiler.

Reproducible: Always

Steps to Reproduce:
1. Build trojita on Windows with Qt 4.8.5, cmake 2.8.11 and VC2010

Actual Results:  
trojita.exe has no application item in the windows file manager

Expected Results:  
there should be an application item, the trijota logo would be great for this. 

Since  couldn't find a way to attaché the patch on big report creation I will add it later.
Comment 1 Christian Degenkolb 2013-08-17 21:35:03 UTC
Created attachment 81761 [details]
patch to add appliaction item support for MS Windows with VC2010

I hope this patch is ok. The windows git client is confusing the hell out of me..
Comment 2 Jan Kundrát 2013-08-18 09:09:23 UTC
Git commit c008b4d795886cb34667cea7c4947c15a3cd8e96 by Jan Kundrát, on behalf of Christian Degenkolb.
Committed on 16/08/2013 at 18:59.
Pushed by jkt into branch 'master'.

GUI: add support for application icon on Windows

Signed-off-by: Jan Kundrát <jkt@flaska.net>

M  +1    -1    CMakeLists.txt
A  +-    --    src/icons/trojita.ico
A  +1    -0    src/trojita_ico_win32.rc

http://commits.kde.org/trojita/c008b4d795886cb34667cea7c4947c15a3cd8e96