Bug 323418 - “Only possible brick” points awarded too generously
Summary: “Only possible brick” points awarded too generously
Status: RESOLVED FIXED
Alias: None
Product: kajongg
Classification: Unclassified
Component: general (show other bugs)
Version: 4.9.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Wolfgang Rohdewald
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-12 15:09 UTC by ospalh@gmail.com
Modified: 2013-08-13 12:53 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.1


Attachments
Image showing undeserved bonus points. (314.66 KB, image/png)
2013-08-12 15:09 UTC, ospalh@gmail.com
Details
Situation where i was waiting for *two* rather than one possible bricks. (297.08 KB, image/png)
2013-08-12 15:11 UTC, ospalh@gmail.com
Details
The scorer missed a hidden pong. (132.80 KB, image/png)
2013-08-13 10:51 UTC, ospalh@gmail.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ospalh@gmail.com 2013-08-12 15:09:39 UTC
Created attachment 81670 [details]
Image showing undeserved bonus points.

The extra points for “Only possible brick”/„Schlussziegel ist einziger möglicher Ziegel“ is awarded in cases where this is not true.

See the attached images. I was waiting for bamboo 2 *or* bamboo 7, got one, and was awarded these bonus points.
Comment 1 ospalh@gmail.com 2013-08-12 15:11:35 UTC
Created attachment 81671 [details]
Situation where i was waiting for *two* rather than one possible bricks.

... i wanted to add two images. Here is another one.
Comment 2 Wolfgang Rohdewald 2013-08-12 16:18:33 UTC
Which version of KDE do you have installed?

You adapted the standard ruleset to your private rules. What did you change?

In the ruleset editor you can compare rulesets and send me the screenshot.
Comment 3 ospalh@gmail.com 2013-08-12 17:03:07 UTC
(In reply to comment #2)
> Which version of KDE do you have installed?
Yum said:
Name        : kdegames
Arch        : x86_64
Epoch       : 6
Version     : 4.9.4
Release     : 1.fc18
Size        : 38 M
Repo        : fedora/18/x86_64
(...)
Description : Games for KDE 4, including:
(...)
            : * kajongg

> 
> You adapted the standard ruleset to your private rules. What did you change?
>
I just switched off the bonus tiles (flowers).
Comment 4 Wolfgang Rohdewald 2013-08-12 21:41:33 UTC
Git commit a28be9d0d683cd5668b8d6457de924ebe41cf201 by Wolfgang Rohdewald.
Committed on 12/08/2013 at 21:40.
Pushed by wrohdewald into branch 'KDE/4.11'.

fix finding alternative tiles for saying MJ
FIXED-IN: 4.11

M  +1    -2    src/hand.py

http://commits.kde.org/kajongg/a28be9d0d683cd5668b8d6457de924ebe41cf201
Comment 5 Wolfgang Rohdewald 2013-08-12 21:48:25 UTC
So this is now fixed in KDE 4.11.1, thank you for your report.

I will not fix it in the old KDE 4.9 which you have installed but you can easily apply the fix by hand editing your copy of hand.py
Comment 6 ospalh@gmail.com 2013-08-13 10:51:29 UTC
Created attachment 81689 [details]
The scorer missed a hidden pong.

I have tried the fix (git commit a28be9d0d683cd5668b8d6457de924ebe41cf201).
The reported problem seems to be gone. Thanks.
But now i have seen something similar.
I am not sure, but i think it may have started appearing with this change.

Anyway. I have just seen the scoring code miss a hidden pong. Possibly by giving precedence to a hidden chi.
Comment 7 Wolfgang Rohdewald 2013-08-13 12:39:35 UTC
Comment on attachment 81689 [details]
The scorer missed a hidden pong.

your screenshot does not show the game number (in the window title), but I need it for reproduction.

Hint: 

kajongg --game=5435435 

can be used to replay a certain game. This seeds the random generator in a reproducible way.
Comment 8 ospalh@gmail.com 2013-08-13 12:53:42 UTC
Oh dear. I guess that bit is gone. I will look out if i see this problem again.