Bug 323312 - Please update embedded libjingle
Summary: Please update embedded libjingle
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: Jabber Plugin (show other bugs)
Version: 1.5.60
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL: http://libjingle.googlecode.com/svn/t...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-09 16:59 UTC by Scott Kitterman
Modified: 2014-06-02 11:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.13.2


Attachments
Allow to build on unknown architectures (1.13 KB, patch)
2013-12-04 22:53 UTC, Pino Toscano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Kitterman 2013-08-09 16:59:03 UTC
The current libjingle errors out on powerpc due to the cpu_arch_ check raising an error on anything but X86 and ARM.  From looking at the code, it appears this has been corrected upstream in libjingle.

Reproducible: Always
Comment 1 Pali Rohár 2013-08-11 13:56:15 UTC
Problem is that last libjingle code at svn has non-working sound support via mediastream. So updating libjingle is not easy...
Comment 2 Scott Kitterman 2013-08-11 14:10:15 UTC
Perhaps it would be possible to extract that cpu_arch_ changes and apply them to the current embedded version in kopete?
Comment 3 Pali Rohár 2013-08-11 18:06:03 UTC
Yes, it is possible, but I do not have motivation to work on libjingle code, because google dropping xmpp/jabber/libjingle support.
Comment 4 Pali Rohár 2013-10-26 12:00:56 UTC
Just to note that upstream google repository is now here: https://code.google.com/p/webrtc/source/browse/#svn/trunk/talk

If you know which patches are needed, I can backport them to kopete tree.
Comment 5 Pino Toscano 2013-12-04 22:51:55 UTC
(In reply to comment #2)
> Perhaps it would be possible to extract that cpu_arch_ changes and apply
> them to the current embedded version in kopete?

Part of libjingle's r305 allows kopete to build on architectures different than x86/x86_64/arm. I'm attaching the extracted part of it.
Comment 6 Pino Toscano 2013-12-04 22:53:00 UTC
Created attachment 83938 [details]
Allow to build on unknown architectures
Comment 7 Pali Rohár 2014-06-02 11:41:55 UTC
Git commit 545504ab771df134f377ca093b627dbe82dc7c20 by Pali Rohár.
Committed on 21/05/2014 at 13:01.
Pushed by pali into branch 'master'.

Allow to build libjingle on unknown architectures

Thanks Pino Toscano for patch!

A  +32   -0    protocols/jabber/googletalk/libjingle/patches/06_libjingle_unknown_architecture.patch
M  +3    -3    protocols/jabber/googletalk/libjingle/talk/base/systeminfo.cc
M  +1    -0    protocols/jabber/googletalk/libjingle/talk/base/systeminfo.h

http://commits.kde.org/kopete/545504ab771df134f377ca093b627dbe82dc7c20
Comment 8 Pali Rohár 2014-06-02 11:42:43 UTC
Git commit 1d3f611c83143c34b6c4dae21b7a8e919f05bae5 by Pali Rohár.
Committed on 21/05/2014 at 13:01.
Pushed by pali into branch 'KDE/4.13'.

Allow to build libjingle on unknown architectures

Thanks Pino Toscano for patch!
FIXED-IN: 4.13.2

A  +32   -0    protocols/jabber/googletalk/libjingle/patches/06_libjingle_unknown_architecture.patch
M  +3    -3    protocols/jabber/googletalk/libjingle/talk/base/systeminfo.cc
M  +1    -0    protocols/jabber/googletalk/libjingle/talk/base/systeminfo.h

http://commits.kde.org/kopete/1d3f611c83143c34b6c4dae21b7a8e919f05bae5