Bug 323260 - Nepomuk backup does not restore comments
Summary: Nepomuk backup does not restore comments
Status: RESOLVED FIXED
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: 4.10.97
Platform: Kubuntu Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: Nepomuk Bugs Coordination
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-07 13:37 UTC by kdeuser56
Modified: 2013-08-11 06:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kdeuser56 2013-08-07 13:37:41 UTC
When restoring a backup containing tags, ratings and comments made in dolphin, only tags and ratings but not the comments are restored. 

Reproducible: Always

Steps to Reproduce:
1. Restore a backup using nepomuk backup utility 
2. Look for comments and see that all entries are empty
Comment 1 Vishesh Handa 2013-08-11 06:36:58 UTC
Git commit 2427dc8bb2559d47ca8a9a8ba31f35c6c5e7bbda by Vishesh Handa.
Committed on 08/08/2013 at 17:39.
Pushed by vhanda into branch 'KDE/4.11'.

Backup Statement Generator: statements without a datatype can be valid

In Nepomuk the nao:description is stored as an rdfs literal, which means
it doesn't have a datatype, but is supposed to have a language tag.
Since we don't store the language tag, it is just stored as a string.
This used to be considered invalid by the statement generator and
therefore the nao:description (dolphin comments) was never backed up
even though it was requested.

Also added unit test
REVIEW: 111947

M  +8    -0    autotests/test/backuptests.cpp
M  +5    -1    services/storage/backup/statementgenerator.cpp

http://commits.kde.org/nepomuk-core/2427dc8bb2559d47ca8a9a8ba31f35c6c5e7bbda