Bug 322852 - Quick maximizing doesn't work when window already has maximized size
Summary: Quick maximizing doesn't work when window already has maximized size
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.10.95
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-26 17:04 UTC by Kai Uwe Broulik
Modified: 2013-08-02 20:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2013-07-26 17:04:57 UTC
When a window has the same size as it would have when maximized (VLC seems to do this quite often), quick maximizing by dragging the window to the top doesn't work. No rectangle appears, and the window doesn't maximize. First dragging it to quick tile somewhere else and then maximizing works.

Xwininfo:

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x2200002 "n-BXNXvTvV4.mp4 - VLC media player"

  Absolute upper-left X:  0
  Absolute upper-left Y:  55
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 1920
  Height: 1025
  Depth: 24
  Visual: 0x21
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +0+55  -0+55  -0-0  +0-0
  -geometry 1920x1025+0-0

My screen resolution is 1920x1080 with a 55px panel at the top

Reproducible: Always

Steps to Reproduce:
1. Open a FullHD video in VLC (?)
2. Try quick maximizing window
3.
Actual Results:  
Doesn't work

Expected Results:  
Works
Comment 1 Thomas Lübking 2013-07-26 18:01:44 UTC
"When a window has the same size as it would have when maximized"
This translates to:
"When a window STARTS with the same size as it would have when maximized"?

In that case the window actually is initially maximized (check "xprop | grep _NET_WM_STATE")

Now you got to explain why you'd expect a maximized window to perform quick maximization ;-)
Comment 2 Kai Uwe Broulik 2013-07-26 18:18:13 UTC
It's not maximized, it has decoration (have borderless maximized windows enabled) and can be maximized and restored
Comment 3 Thomas Lübking 2013-07-26 18:24:22 UTC
Please attach the complete "xprop" output then.
Comment 4 Kai Uwe Broulik 2013-07-27 08:49:12 UTC
_NET_WM_ALLOWED_ACTIONS(ATOM) = _NET_WM_ACTION_MOVE, _NET_WM_ACTION_RESIZE, _NET_WM_ACTION_MINIMIZE, _NET_WM_ACTION_SHADE, _NET_WM_ACTION_MAXIMIZE_VERT, _NET_WM_ACTION_MAXIMIZE_HORZ, _NET_WM_ACTION_FULLSCREEN, _NET_WM_ACTION_CHANGE_DESKTOP, _NET_WM_ACTION_CLOSE
_KDE_NET_WM_FRAME_STRUT(CARDINAL) = 0, 0, 27, 0
_NET_FRAME_EXTENTS(CARDINAL) = 0, 0, 27, 0
_NET_WM_DESKTOP(CARDINAL) = 0
_KDE_NET_WM_ACTIVITIES(STRING) = "c48aa374-5fb6-4d99-bea6-a2e1f57ea436"
WM_STATE(WM_STATE):
		window state: Normal
		icon window: 0x0
_NET_WM_STATE(ATOM) = _NET_WM_STATE_MAXIMIZED_HORZ
_NET_WM_SYNC_REQUEST_COUNTER(CARDINAL) = 52428834
_KDE_OXYGEN_BACKGROUND_PIXMAP(CARDINAL) = 0
_KDE_OXYGEN_BACKGROUND_GRADIENT(CARDINAL) = 1
_NET_WM_ICON(CARDINAL) = 	Icon (32 x 32):
	                                
	               ▒▒               
	              ▒░░▒              
	              ░░░░              
	              ░░░░              
	             ░░░░░░             
	                                
	                  ░             
	                                
	                                
	                                
	            ▒░░░░░░▒            
	           ▒▒░░░░░░▒▒           
	           ▒░░░░░░░▒▒           
	           ▒░░░░░░░▒▒           
	          ▒▒░░░░░░░░▒▒          
	          ░░░░░░░░░░░░          
	          ░ ░░░░░░░░░           
	         ░           ░░         
	          ░         ░ ░         
	         ░           ░          
	        ▒░            ░▒        
	       ▒▒▒░░         ░▒▒▒       
	      ░▒▒▒▒▒░░░░░░░░░▒▒▒▒▒      
	     ░░▒▒▒▒▒░▒▒░░░░░░▒▒▒▒░░     
	    ░░░░░▒▒▒░▒▒░░░░░░▒▒░░░░░    
	   ░░░░░░░░▒▒▒▒▒░░░░░░░░░░░░░   
	                                
	   ▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒   
	                                
	                                
	                                


XdndAware(ATOM) = BITMAP
_MOTIF_DRAG_RECEIVER_INFO(_MOTIF_DRAG_RECEIVER_INFO) = 0x6c, 0x0, 0x5, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x10, 0x0, 0x0, 0x0
_NET_WM_NAME(UTF8_STRING) = "jDELybyZ4oU.mp4 - VLC media player"
WM_CLIENT_LEADER(WINDOW): window id # 0x3200004
WM_WINDOW_ROLE(STRING) = "vlc-main"
_NET_WM_PID(CARDINAL) = 3550
_NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_NORMAL
_MOTIF_WM_HINTS(_MOTIF_WM_HINTS) = 0x3, 0x3e, 0x7e, 0x0, 0x0
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW, WM_TAKE_FOCUS, _NET_WM_PING, _NET_WM_SYNC_REQUEST
_KDE_NET_WM_USER_CREATION_TIME(CARDINAL) = 32193102
WM_NAME(STRING) = "jDELybyZ4oU.mp4 - VLC media player"
WM_LOCALE_NAME(STRING) = "de_DE.UTF-8"
WM_CLASS(STRING) = "vlc", "Vlc"
WM_HINTS(WM_HINTS):
		Client accepts input or input focus: True
		Initial state is Normal State.
		bitmap id # to use for icon: 0x320000d
		window id # of group leader: 0x3200004
WM_NORMAL_HINTS(WM_SIZE_HINTS):
		user specified location: 0, 28
		program specified location: 0, 28
		user specified size: 1920 by 887
		program specified size: 1920 by 887
		program specified minimum size: 435 by 55
		window gravity: NorthWest
WM_CLIENT_MACHINE(STRING) = "kaiuwe-tragbar2"
WM_COMMAND(STRING) = { "vlc" }
Comment 5 Thomas Lübking 2013-07-27 09:15:25 UTC
That's a funny one - quick maximization only works when moving the window to the top and then perform an additional slight horizontal move - what does not work if the window is guided because either (in this case) it's horizontally maximized or du to screen snapping.

No idea whether the mentioned behavior is intended, though.
Comment 6 Martin Flöser 2013-07-29 04:52:39 UTC
> No idea whether the mentioned behavior is intended, though.
I would say no
Comment 7 Thomas Lübking 2013-08-02 20:58:15 UTC
Git commit 652d1c1cade55adb3a9ed87a29859d76d749578d by Thomas Lübking.
Committed on 27/07/2013 at 11:09.
Pushed by luebking into branch 'KDE/4.11'.

don't require geometry changes for quick max/tile

the present check can break quick everything depending
on screen snapping settings.
It so far. only worked for quick maximization due to horizontal
"judder" and failed whenever that judder was not possible
(due to screen snapping on left and/or right edge)
FIXED-IN: 4.11
REVIEW: 111740

M  +3    -3    kwin/events.cpp

http://commits.kde.org/kde-workspace/652d1c1cade55adb3a9ed87a29859d76d749578d