Bug 322324 - Move Layer content (movea layer tool) doesnt´t work
Summary: Move Layer content (movea layer tool) doesnt´t work
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: git master (please specify the git hash!)
Platform: Ubuntu Packages Linux
: NOR major
Target Milestone: ---
Assignee: Krita Bugs
URL: https://www.dropbox.com/s/xxjsc14tmrn...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-13 21:17 UTC by RamonMiranda
Modified: 2013-08-27 19:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RamonMiranda 2013-07-13 21:17:05 UTC
see the attached video

Reproducible: Always

Steps to Reproduce:
see the attached video.

1. Select the move a layer tool
2. try to move a layer with content clicking in an area with content but with another layer selected.
3. works the first time but if yo slect anothe layer content, it stops to work.
Actual Results:  
The layer that is suposed to move , doesn´t move.

Expected Results:  
The program must to select the right layer based on the content (pixel) that is under the cursor.
Comment 1 Halla Rempt 2013-07-20 09:52:46 UTC
Yes, I can confirm. This is a regression, I think
Comment 2 Dmitry Kazakov 2013-08-08 20:17:18 UTC
This is a regression after porting the Move Tool to incremental strokes. The stroke is started for a single node, and the only way to finish the stroke is to either press Enter or Deactivate the Move Tool or to Select any other layer. After one of these actions has happened, the stroke will be finished and any user action will start a new stroke (with another node).

We should either allow the stroke to work with different layers, or just finish the stroke, when there is another candidate for the moving.
Comment 3 Dmitry Kazakov 2013-08-27 19:31:39 UTC
Git commit c2076fa53a2afc58986444045d20635042256e5b by Dmitry Kazakov.
Committed on 27/08/2013 at 19:29.
Pushed by dkazakov into branch 'master'.

Restart the move tool stroke when the target node has changed

The target node can change due to the "Move Layer with Content" option
which was not taken into account previously.

M  +14   -2    krita/plugins/tools/defaulttools/kis_tool_move.cc
M  +1    -0    krita/plugins/tools/defaulttools/kis_tool_move.h

http://commits.kde.org/calligra/c2076fa53a2afc58986444045d20635042256e5b