Bug 320607 - Docker "REFERENCE IMAGES" is not displaying JPG/JPEG images, is not allowing to change disk
Summary: Docker "REFERENCE IMAGES" is not displaying JPG/JPEG images, is not allowing ...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Dockers (show other bugs)
Version: 2.8 Pre-Alpha
Platform: Microsoft Windows Microsoft Windows
: NOR major
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-02 10:17 UTC by slawek
Modified: 2013-07-09 10:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of imagedocker on win8 (685.98 KB, image/png)
2013-06-21 07:31 UTC, Halla Rempt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description slawek 2013-06-02 10:17:15 UTC
Docker is not displaying any JPEG images - PNG seems to work. Docker also is not allowing to change disk either by clicking on drop down menu (nothing is happening) or by typing in other letter of disk.

Reproducible: Always

Steps to Reproduce:
1.Turn on REFERENCE IMAGES docker
2.Browse to catalog with JPG/JPEG images - you will notice that none of them will be shown
3.Try to change disk in order to browse for references - either by clicking on drop down menu or typing in other destination in address 
Actual Results:  
None of JPG/JPEG files will be shown in docker. Changing disk will prove impossible.

Expected Results:  
Docker REFERENCE IMAGES is one of the most important ones, it should show most popular picture format which is JPG/JPEG. Also on windows changing disks in order to browse for references is substantial. Its importance is growing with popularity of SSD disks which are used for system, not for storage. Docker should made possible changing disk.
Comment 1 Halla Rempt 2013-06-20 10:39:18 UTC
Hm, I just tested on Windows and saw jpg files in the file list and could show them. The issue with the drive letters is because the original author built his own directory browser instead of re-using a component.  I'll see whether that can be replaced.
Comment 2 slawek 2013-06-20 17:06:27 UTC
Here is screenshot to prove that not everything works. I did a folder with randomly downloaded pictures from internet. Few jpgs, 1 jpg renamed to png (just to check reaction if it is related just to  extension), 1 png and 1 PSD. You can see opened folder on the screen and what docker is actually showing. Reacted only to PNG, showed existence of PSD as well. Car picture named "example5.PNG" is in fact a jpg file - didnt showed up as well....

http://i.imgur.com/2UU3YGH.jpg
Comment 3 Halla Rempt 2013-06-21 07:26:42 UTC
Git commit 5f3bc49530b3de28f0f992059747e1a5f2c5750f by Boudewijn Rempt.
Committed on 21/06/2013 at 07:19.
Pushed by rempt into branch 'master'.

Change the image docker combobox to show common locations and drives

M  +1    -1    krita/plugins/extensions/dockers/imagedocker/forms/wdgimagedocker.ui
M  +22   -4    krita/plugins/extensions/dockers/imagedocker/imagedocker_dock.cpp
M  +1    -0    krita/plugins/extensions/dockers/imagedocker/imagedocker_dock.h

http://commits.kde.org/calligra/5f3bc49530b3de28f0f992059747e1a5f2c5750f
Comment 4 Halla Rempt 2013-06-21 07:31:29 UTC
Created attachment 80678 [details]
screenshot of imagedocker on win8

I have added drives and common places. I'm not sure I can do anything about your jpg issue. As you can see from this screenshot, it works fine on my test system. I'll make a new build this weekend/early next week for you to test.
Comment 5 slawek 2013-06-21 10:40:13 UTC
Ow I appreciate that a LOT. Thank you. 
You know, funny thing is it was working before on the same very system and I am not a person that bloats system with some nonsense. I am keeping it at its minimum and trying to keep it as clean as possible. This issue is fairly new but I would say at least 2 last builds were affected.
Comment 6 Halla Rempt 2013-06-21 10:41:17 UTC
Maybe in one or two installers I had forgotten to add the Qt jpeg loader plugin...
Comment 7 slawek 2013-06-21 11:18:03 UTC
Hahaha! "Maybe" you say... ;) Thank you again for looking into it! I cant wait for new build.