Bug 320269 - Menubar should be toggle-able (with patch)
Summary: Menubar should be toggle-able (with patch)
Status: RESOLVED FIXED
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other All
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-25 18:39 UTC by Matt Scheirer
Modified: 2013-06-14 02:26 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments
Patch to enable ctrl-m (by default) to toggle the menubar, with a prompt. (2.33 KB, patch)
2013-05-25 18:40 UTC, Matt Scheirer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Scheirer 2013-05-25 18:39:37 UTC
The menubar of kpat isn't toggleable. Since my grandfather plays it 24/7 pretty much, I was running into issues where he would remove the main toolbar, either in settings or via right clicking the menubar, while errantly clicking around cards. So I wrote a patch to implement the KStandardAction:showMenubar so I can toggle it and he can avoid removing the main toolbar through its settings.

There is also a continuewaitcancel dialog to confirm when you use ctrl-m (or whatever you assign the shortcut to) you want to toggle the menubar off.

Only issue I could see is I'm pulling in KStandardAction since showMenubar isn't a part ofKStandardGameAction. Diff is attached below.

Reproducible: Always
Comment 1 Matt Scheirer 2013-05-25 18:40:18 UTC
Created attachment 80075 [details]
Patch to enable ctrl-m (by default) to toggle the menubar, with a prompt.
Comment 2 Burkhard Lück 2013-05-26 08:58:55 UTC
(In reply to comment #1)
> Created attachment 80075 [details]
> Patch to enable ctrl-m (by default) to toggle the menubar, with a prompt.

Please use git.reviewboard.kde.org for your patch and add kdegames als review group.
Thanks
Comment 3 Albert Astals Cid 2013-06-11 21:16:27 UTC
Git commit 90db9eaac05e7029078e3e292c3f79570c5dd1fa by Albert Astals Cid, on behalf of Matt Scheirer.
Committed on 11/06/2013 at 23:15.
Pushed by aacid into branch 'master'.

Enable ctrl-m (by default) to toggle the menubar

This is considered an accessibility/usability bugfix by the kdegames crew
The i18n teams have acked the new messages

REVIEW: 110650
FIXED-IN: 4.11.0

M  +24   -1    mainwindow.cpp
M  +2    -0    mainwindow.h

http://commits.kde.org/kpat/90db9eaac05e7029078e3e292c3f79570c5dd1fa
Comment 4 Ian Wadham 2013-06-14 02:26:06 UTC
Thank you very much, Albert, for doing this and for taking the trouble to squeeze it in at what must have been a very busy time for you.