Bug 316169 - okular cannot open some eps files
Summary: okular cannot open some eps files
Status: RESOLVED UPSTREAM
Alias: None
Product: okular
Classification: Applications
Component: PS backend (show other bugs)
Version: 0.16.0
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
: 330019 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-05 13:22 UTC by thomas.gastine
Modified: 2014-01-17 08:05 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
example eps file (300.65 KB, application/octet-stream)
2013-03-05 13:24 UTC, thomas.gastine
Details
example eps file (300.65 KB, application/octet-stream)
2013-03-05 13:25 UTC, thomas.gastine
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thomas.gastine 2013-03-05 13:22:53 UTC
okular 0.16 cannot open some eps files:
undefined -21
okular(19291)/okular (Spectre) GSRendererThread::run: Generated image does not match wanted size: [0x0] vs requested [691x698]
QImage::scaled: Image is a null image
undefined -21

It used to work flawlessly with previous versions. It is only happening for some eps files.

Reproducible: Always

Steps to Reproduce:
1. try to open some eps files
2. 
3.
Actual Results:  
only a white frame is visible

Expected Results:  
see the proper figure

An example is provided in the URL: this file can be opened with okular 0.10.4 but not with the 0.16.
Comment 1 thomas.gastine 2013-03-05 13:24:26 UTC
Created attachment 77770 [details]
example eps file

This file can be opened with okular 0.10.4 but not with 0.16
Comment 2 thomas.gastine 2013-03-05 13:25:35 UTC
Created attachment 77771 [details]
example eps file

This file can be opened with okular 0.10.4 but not with 0.16
Comment 3 Yuri Chornoivan 2013-03-06 05:47:14 UTC
The attached image is shown as expected in Okular 0.16.1 (Ghostscript backend (gs 9.05), 32-bits).

What Ghostscript version do you use?
Comment 4 Antonio Rojas 2013-03-06 07:41:25 UTC
This is caused by the ghostscript 9.07 update, which breaks libspectre:

https://bugs.archlinux.org/task/33971
https://bugs.freedesktop.org/show_bug.cgi?id=61506
Comment 5 Albert Astals Cid 2013-03-06 23:12:56 UTC
Not much we can do at the Okular level, i'll try to have a look at the spectre sources and see what's going on.
Comment 6 thomas.gastine 2013-03-07 10:52:45 UTC
Indeed, downgrading to ghostscrip 9.06 works. In addition, it seems that a simple eps2eps on the figure is enough to make it visible with okular 0.16, gs 9.07.
Comment 7 Albert Astals Cid 2014-01-17 08:05:07 UTC
*** Bug 330019 has been marked as a duplicate of this bug. ***