Bug 316086 - Kget 4.10 deletes home
Summary: Kget 4.10 deletes home
Status: RESOLVED FIXED
Alias: None
Product: kget
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: Lukas Appelhans
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-03 19:38 UTC by Eddy
Modified: 2013-03-07 11:08 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.2


Attachments
Fix (627 bytes, patch)
2013-03-05 16:50 UTC, Lukas Appelhans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eddy 2013-03-03 19:38:55 UTC
Using kget 4.10 as usual, there is a random behavior with finished downloads that get renamed automatically with my username and changed the download path to /home/username. So when trying to delete the download from the list, my entire home folder got deleted (including hidden files). Same happens if I retry the download.

I couldn't reproduce the problem because for most downloads it does fine.
The last time was with files over 600MB in direct download http.

Reproducible: Sometimes
Comment 1 Lukas Appelhans 2013-03-03 19:49:15 UTC
Can you provide a url with which it happened?

Also please describe the steps you did while adding the download.
Comment 2 Eddy 2013-03-03 22:21:50 UTC
OK, I could reproduce the problem again and it's not with finished but with failed downloads.
Here are a few screenshots: http://imgur.com/a/7YUxx
Here are those 3 links: http://pastebin.com/H2pAfakU

I added the download using rekonq 2.2 from the filehost putlocker.com and used internet in other stuff to make fail kget.

Personal comment: I was confused at first because this happened to me a few days ago but I thought it was my fault, then it happened again today while I left my PC downloading those files but I thought they were completed downloaded because they had the same size indicated in dolphin. But apparently kget gives them dummy size or something.
Comment 3 Lukas Appelhans 2013-03-05 10:54:47 UTC
Thanks for the detailed report, I will work on a fix later today!

Lukas
Comment 4 Lukas Appelhans 2013-03-05 16:50:17 UTC
Created attachment 77778 [details]
Fix

Can you test this patch and report if it works for you?

Lukas
Comment 5 Brallan Aguilar 2013-03-05 20:17:32 UTC
I also have this problem. Additionally, I was downloading some photos to my Picture folder in another partition, and my folder was deleted so.
Comment 6 Eddy 2013-03-05 22:24:21 UTC
Tested with the patch and it works for me.
Comment 7 Lukas Appelhans 2013-03-06 01:07:44 UTC
Yes, it appears to me that KIO at some points reports a filename change to an empty string. This adds a check to catch this.

I will commit this tomorrow!

Thanks for reporting!

Lukas
Comment 8 Lukas Appelhans 2013-03-07 10:29:51 UTC
SVN commit 1343275 by lappelhans:

Handle the case when KIO returns an empty filename




 M  +2 -0      transfermultisegkio.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1343275
Comment 9 Lukas Appelhans 2013-03-07 10:33:17 UTC
SVN commit 1343276 by lappelhans:

Backport SVN commit 1343275 by lappelhans:

Handle the case when KIO returns an empty filename

FIXED-IN:4.10


 M  +2 -0      transfermultisegkio.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1343276