Bug 315491 - Kirsk Crash
Summary: Kirsk Crash
Status: RESOLVED FIXED
Alias: None
Product: ksirk
Classification: Unclassified
Component: general (show other bugs)
Version: 4.9.4
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Nemanja Hirsl
URL:
Keywords:
: 325688 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-20 04:34 UTC by Kelly
Modified: 2013-10-06 11:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kelly 2013-02-20 04:34:08 UTC
Application: ksirk (4.9.4)
KDE Platform Version: 4.9.4
Qt Version: 4.8.3
Operating System: Linux 3.5.0-24-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:
I had enabled the battlefield just before the last battle.  I selected automatic and it crashed just as it was finishing the battle.

- Custom settings of the application:
Battlefield mode enabled.

-- Backtrace:
Application: KsirK (ksirk), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd853f9b780 (LWP 26013))]

Thread 7 (Thread 0x7fd837fff700 (LWP 26017)):
#0  0x00007fd84fc35313 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd84c27cd84 in g_main_context_poll (n_fds=3, fds=0x7fd8300010c0, timeout=-1, context=0x7fd83800c4e0, priority=<optimized out>) at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:3584
#2  g_main_context_iterate (context=0x7fd83800c4e0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:3285
#3  0x00007fd84c27d1e2 in g_main_loop_run (loop=0x7fd83800c470) at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:3484
#4  0x00007fd8441eb4a6 in gdbus_shared_thread_func (user_data=0x7fd83800c4b0) at /build/buildd/glib2.0-2.34.1/./gio/gdbusprivate.c:277
#5  0x00007fd84c2a0645 in g_thread_proxy (data=0x7fd83800b230) at /build/buildd/glib2.0-2.34.1/./glib/gthread.c:797
#6  0x00007fd84d8cbe9a in start_thread (arg=0x7fd837fff700) at pthread_create.c:308
#7  0x00007fd84fc40ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fd816619700 (LWP 26853)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fd84c2ba09f in g_cond_wait (cond=0x12c4020, mutex=<optimized out>) at /build/buildd/glib2.0-2.34.1/./glib/gthread-posix.c:746
#2  0x00007fd821c48e25 in ?? () from /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstcoreelements.so
#3  0x00007fd82d95fdb1 in gst_pad_push () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#4  0x00007fd82d95fdb1 in gst_pad_push () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#5  0x00007fd821c545e0 in ?? () from /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstcoreelements.so
#6  0x00007fd821c54adf in ?? () from /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstcoreelements.so
#7  0x00007fd82d95fdb1 in gst_pad_push () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#8  0x00007fd821c49df6 in ?? () from /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstcoreelements.so
#9  0x00007fd82d985e34 in ?? () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#10 0x00007fd84c2a0e62 in g_thread_pool_thread_proxy (data=<optimized out>) at /build/buildd/glib2.0-2.34.1/./glib/gthreadpool.c:309
#11 0x00007fd84c2a0645 in g_thread_proxy (data=0x7fd810081e80) at /build/buildd/glib2.0-2.34.1/./glib/gthread.c:797
#12 0x00007fd84d8cbe9a in start_thread (arg=0x7fd816619700) at pthread_create.c:308
#13 0x00007fd84fc40ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fd804856700 (LWP 26857)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fd84c2ba09f in g_cond_wait (cond=0x7fd83824a630, mutex=<optimized out>) at /build/buildd/glib2.0-2.34.1/./glib/gthread-posix.c:746
#2  0x00007fd82d986003 in ?? () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#3  0x00007fd84c2a0e62 in g_thread_pool_thread_proxy (data=<optimized out>) at /build/buildd/glib2.0-2.34.1/./glib/gthreadpool.c:309
#4  0x00007fd84c2a0645 in g_thread_proxy (data=0x7fd81c03a5e0) at /build/buildd/glib2.0-2.34.1/./glib/gthread.c:797
#5  0x00007fd84d8cbe9a in start_thread (arg=0x7fd804856700) at pthread_create.c:308
#6  0x00007fd84fc40ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fd822a8b700 (LWP 26858)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fd84c2ba09f in g_cond_wait (cond=0x7fd7fc1eea20, mutex=<optimized out>) at /build/buildd/glib2.0-2.34.1/./glib/gthread-posix.c:746
#2  0x00007fd82d986003 in ?? () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#3  0x00007fd84c2a0e62 in g_thread_pool_thread_proxy (data=<optimized out>) at /build/buildd/glib2.0-2.34.1/./glib/gthreadpool.c:309
#4  0x00007fd84c2a0645 in g_thread_proxy (data=0x7fd81c03a6d0) at /build/buildd/glib2.0-2.34.1/./glib/gthread.c:797
#5  0x00007fd84d8cbe9a in start_thread (arg=0x7fd822a8b700) at pthread_create.c:308
#6  0x00007fd84fc40ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fd815e18700 (LWP 26859)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fd84c2ba09f in g_cond_wait (cond=0x12b3490, mutex=<optimized out>) at /build/buildd/glib2.0-2.34.1/./glib/gthread-posix.c:746
#2  0x00007fd82c90d6dc in gst_base_sink_wait_preroll () from /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0
#3  0x00007fd822aab688 in ?? () from /usr/lib/x86_64-linux-gnu/libgstaudio-0.10.so.0
#4  0x00007fd82c90fc3f in ?? () from /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0
#5  0x00007fd82c91163f in ?? () from /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0
#6  0x00007fd82c911b48 in ?? () from /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0
#7  0x00007fd82c911e7f in ?? () from /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0
#8  0x00007fd82d95fdb1 in gst_pad_push () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#9  0x00007fd82c91f8dc in ?? () from /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0
#10 0x00007fd82d95fdb1 in gst_pad_push () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#11 0x00007fd82c91f8dc in ?? () from /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0
#12 0x00007fd82d95fdb1 in gst_pad_push () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#13 0x00007fd82c91f8dc in ?? () from /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0
#14 0x00007fd82d95fdb1 in gst_pad_push () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#15 0x00007fd821c49df6 in ?? () from /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstcoreelements.so
#16 0x00007fd82d985e34 in ?? () from /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0
#17 0x00007fd84c2a0e62 in g_thread_pool_thread_proxy (data=<optimized out>) at /build/buildd/glib2.0-2.34.1/./glib/gthreadpool.c:309
#18 0x00007fd84c2a0645 in g_thread_proxy (data=0x7fd800003230) at /build/buildd/glib2.0-2.34.1/./glib/gthread.c:797
#19 0x00007fd84d8cbe9a in start_thread (arg=0x7fd815e18700) at pthread_create.c:308
#20 0x00007fd84fc40ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#21 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd81761b700 (LWP 26866)):
#0  0x00007fd84fc35313 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd84e021b6f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007fd84e0130b5 in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007fd84e013719 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007fd84e0137d0 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007fd84e021b1f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007fd849757543 in ?? () from /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-2.1.so
#7  0x00007fd84d8cbe9a in start_thread (arg=0x7fd81761b700) at pthread_create.c:308
#8  0x00007fd84fc40ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd853f9b780 (LWP 26013)):
[KCrash Handler]
#6  0x00000000004a5507 in Ksirk::GameLogic::Player::flagFileName (this=<optimized out>) at ../../../ksirk/ksirk/GameLogic/player.cpp:226
#7  0x000000000048f03e in Ksirk::GameLogic::Country::createArmiesSprites (this=0xe866d0) at ../../../ksirk/ksirk/GameLogic/country.cpp:189
#8  0x000000000042f257 in Ksirk::GameLogic::GameAutomaton::slotNetworkData (this=0x1084a60, msgid=<optimized out>, buffer=..., receiver=0, sender=1) at ../../../ksirk/ksirk/GameLogic/gameautomaton.cpp:2198
#9  0x00007fd8505b2f5f in QMetaObject::activate (sender=0x1084a60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff726c1670) at kernel/qobject.cpp:3547
#10 0x00007fd852429a03 in KGame::signalNetworkData (this=this@entry=0x1084a60, _t1=_t1@entry=275, _t2=..., _t3=_t3@entry=0, _t4=_t4@entry=1) at ./kgame.moc:206
#11 0x00007fd852431ace in KGame::networkTransmission (this=0x1084a60, stream=..., msgid=531, receiver=0, sender=1) at ../../libkdegames/libkdegamesprivate/kgame/kgame.cpp:1047
#12 0x00007fd8524381b0 in KGameNetwork::receiveNetworkTransmission (this=0x1084a60, receiveBuffer=..., clientID=1) at ../../libkdegames/libkdegamesprivate/kgame/kgamenetwork.cpp:505
#13 0x00007fd85243855f in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./kgamenetwork.moc:73
#14 KGameNetwork::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./kgamenetwork.moc:62
#15 0x00007fd8505b2f5f in QMetaObject::activate (sender=0x1085060, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff726c1970) at kernel/qobject.cpp:3547
#16 0x00007fd85243e633 in KMessageClient::broadcastReceived (this=this@entry=0x1085060, _t1=..., _t2=_t2@entry=1) at ./kmessageclient.moc:133
#17 0x00007fd85243f42b in processMessage (msg=..., this=0x1085060) at ../../libkdegames/libkdegamesprivate/kgame/kmessageclient.cpp:226
#18 KMessageClient::processMessage (this=0x1085060, msg=...) at ../../libkdegames/libkdegamesprivate/kgame/kmessageclient.cpp:203
#19 0x00007fd85243efc1 in KMessageClient::processIncomingMessage (this=0x1085060, msg=...) at ../../libkdegames/libkdegamesprivate/kgame/kmessageclient.cpp:199
#20 0x00007fd8505b2f5f in QMetaObject::activate (sender=0x1085530, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff726c1bc0) at kernel/qobject.cpp:3547
#21 0x00007fd852440f92 in KMessageIO::received (this=<optimized out>, _t1=...) at ./kmessageio.moc:105
#22 0x00007fd852440fb3 in KMessageDirect::send (this=<optimized out>, msg=...) at ../../libkdegames/libkdegamesprivate/kgame/kmessageio.cpp:214
#23 0x00007fd85244363b in KMessageServer::broadcastMessage (this=0x1084c20, msg=...) at ../../libkdegames/libkdegamesprivate/kgame/kmessageserver.cpp:355
#24 0x00007fd852444de5 in KMessageServer::processOneMessage (this=0x1084c20) at ../../libkdegames/libkdegamesprivate/kgame/kmessageserver.cpp:432
#25 0x00007fd8505b2f5f in QMetaObject::activate (sender=0x1084d30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#26 0x00007fd8505b226c in QObject::event (this=0x1084d30, e=<optimized out>) at kernel/qobject.cpp:1157
#27 0x00007fd850f7ee9c in QApplicationPrivate::notify_helper (this=this@entry=0xe21900, receiver=receiver@entry=0x1084d30, e=e@entry=0x7fff726c2510) at kernel/qapplication.cpp:4562
#28 0x00007fd850f8330a in QApplication::notify (this=0x7fff726c2a60, receiver=0x1084d30, e=0x7fff726c2510) at kernel/qapplication.cpp:4423
#29 0x00007fd851c871d6 in KApplication::notify (this=0x7fff726c2a60, receiver=0x1084d30, event=0x7fff726c2510) at ../../kdeui/kernel/kapplication.cpp:311
#30 0x00007fd85059d56e in QCoreApplication::notifyInternal (this=0x7fff726c2a60, receiver=0x1084d30, event=0x7fff726c2510) at kernel/qcoreapplication.cpp:915
#31 0x00007fd8505ce462 in sendEvent (event=0x7fff726c2510, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#32 QTimerInfoList::activateTimers (this=0xe08c70) at kernel/qeventdispatcher_unix.cpp:611
#33 0x00007fd8505cb584 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#34 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#35 0x00007fd8505cb5a1 in idleTimerSourceDispatch (source=source@entry=0xe08cc0) at kernel/qeventdispatcher_glib.cpp:233
#36 0x00007fd84c27cab5 in g_main_dispatch (context=0xe1a2a0) at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:2715
#37 g_main_context_dispatch (context=context@entry=0xe1a2a0) at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:3219
#38 0x00007fd84c27cde8 in g_main_context_iterate (context=context@entry=0xe1a2a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:3290
#39 0x00007fd84c27cea4 in g_main_context_iteration (context=0xe1a2a0, may_block=1) at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:3351
#40 0x00007fd8505cbbf6 in QEventDispatcherGlib::processEvents (this=0xdd0be0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#41 0x00007fd851023c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00007fd85059c2bf in QEventLoop::processEvents (this=this@entry=0x7fff726c2790, flags=...) at kernel/qeventloop.cpp:149
#43 0x00007fd85059c548 in QEventLoop::exec (this=0x7fff726c2790, flags=...) at kernel/qeventloop.cpp:204
#44 0x00007fd8505a1708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#45 0x0000000000421b08 in main (argc=5, argv=0x7fff726c2bb8) at ../../../ksirk/ksirk/main.cpp:75

Reported using DrKonqi
Comment 1 Nemanja Hirsl 2013-02-23 12:40:49 UTC
Arena has some issues - crashes are the biggest.
Comment 2 Nemanja Hirsl 2013-08-03 21:42:58 UTC
Git commit a6022c9ceb86a55a91769b5ee2585c713d84512d by Nemanja Hirsl.
Committed on 03/08/2013 at 21:37.
Pushed by nhirsl into branch 'KDE/4.11'.

FIXED-IN:4.11.0
Bug 315491 - Kirsk Crash
The main issue is using deleted pointer. There is no need to recreate
sprites if the player is out of the game.

M  +16   -8    ksirk/kgamewin.cpp

http://commits.kde.org/ksirk/a6022c9ceb86a55a91769b5ee2585c713d84512d
Comment 3 Nemanja Hirsl 2013-10-06 11:39:46 UTC
*** Bug 325688 has been marked as a duplicate of this bug. ***