Bug 314339 - scrolling in dolphin is really slow when hidden files are shown
Summary: scrolling in dolphin is really slow when hidden files are shown
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: view-engine: icons mode (show other bugs)
Version: 2.1
Platform: Archlinux Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-03 08:21 UTC by Alex Levkovich
Modified: 2013-08-14 21:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Levkovich 2013-02-03 08:21:46 UTC
When I enable the option "Show Hidden Files" scrolling becomes really slow in dolphin.

Reproducible: Always

Steps to Reproduce:
1. enable the option "Show Hidden Files" in menu

Actual Results:  
scrolling is very slow. 

Expected Results:  
scrolling speed should be the same as with "Show Hidden Files" disabled.

video driver: nvidia 313.18. (the same was with drivers < 313.18)
I'm using xrender but it is slow without composite also.
Comment 1 Frank Reininghaus 2013-02-03 23:22:00 UTC
Thanks for the bug report. Sounds like bug 310662, even though that bug only mentions hidden symlinks.
Comment 2 oldwhitemansays 2013-03-09 09:41:41 UTC
I have same issue, tested on KDE 4.8.*-4.10.1 with Gentoo, OpenSuse LiveCD on different computers with ATI's close and open sourced drivers + intel. Compositing OpenGL, graphics system - raster. I thought everybody have this issue, but it seems somebody just have it and somebody not, just like here https://bugs.kde.org/show_bug.cgi?id=233583
Comment 3 oldwhitemansays 2013-03-09 11:29:24 UTC
Video proof:
http://yadi.sk/d/VHrjxNPW393nc 

Same results in compact and details view mode.
Comment 4 Frank Reininghaus 2013-08-14 21:49:15 UTC
Git commit 381b17964d49259955eb5c5e537d290b26c162ef by Frank Reininghaus.
Committed on 14/08/2013 at 21:44.
Pushed by freininghaus into branch 'KDE/4.11'.

Fix slow scrolling when hidden files or symbolic links are shown

The problem was that we drawed the overlays using KIconLoader, which can
be very slow, every time an item appeared on the screen. This commit
makes sure that not only the icon, but the icon including overlays is
cached in QPixmapCache. Therefore, the overlay drawing is done just once
for each icon+overlays combination.

For previews, the overlay drawing is done in KFileItemModelRolesUpdater
just after the preview is received.
Related: bug 310662
FIXED-IN: 4.11.1
REVIEW: 111956

M  +16   -0    dolphin/src/kitemviews/kfileitemmodelrolesupdater.cpp
M  +18   -19   dolphin/src/kitemviews/kstandarditemlistwidget.cpp
M  +1    -1    dolphin/src/kitemviews/kstandarditemlistwidget.h

http://commits.kde.org/kde-baseapps/381b17964d49259955eb5c5e537d290b26c162ef