Bug 313151 - Timeline-Urls can not be set as homepage
Summary: Timeline-Urls can not be set as homepage
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 2.1.97
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2013-01-12 20:33 UTC by m.wege
Modified: 2013-01-22 23:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.wege 2013-01-12 20:33:18 UTC
Timeline-Urls can not be set as homepage. When doing that in settings an error message appears claiming that this url is invalid and will not be used.

Reproducible: Always
Comment 1 Frank Reininghaus 2013-01-14 09:10:13 UTC
Thanks for the bug report. The check that we perform for the new 'home URL' in StartupSettingsPage::applySettings() is

if (url.isValid() && fileItem.isDir())

It seems that the 'timeline' KFileItem is not considered a directory. Maybe this could be fixed by adding an exception for 'timeline' URLs. Looks like a good 'junior job' for potential new contributors.
Comment 2 Andrea Scarpino 2013-01-16 22:07:39 UTC
Git commit 87a4eb9eaf69b8d0d4d873da75d240a410b05ed0 by Andrea Scarpino.
Committed on 16/01/2013 at 23:05.
Pushed by scarpino into branch 'master'.

Allow Timeline-URLs as homepage
REVIEW: 108428

M  +1    -1    dolphin/src/settings/startup/startupsettingspage.cpp

http://commits.kde.org/kde-baseapps/87a4eb9eaf69b8d0d4d873da75d240a410b05ed0
Comment 3 Andrea Scarpino 2013-01-16 22:19:43 UTC
Git commit 26cf73dcac2754db05a142662869179f72a536fe by Andrea Scarpino.
Committed on 16/01/2013 at 23:05.
Pushed by scarpino into branch 'KDE/4.10'.

Allow Timeline-URLs as homepage
REVIEW: 108428

M  +1    -1    dolphin/src/settings/startup/startupsettingspage.cpp

http://commits.kde.org/kde-baseapps/26cf73dcac2754db05a142662869179f72a536fe