Bug 312985 - Dockers are much wider when opening, than they were on close, when statistics docker is open
Summary: Dockers are much wider when opening, than they were on close, when statistics...
Status: RESOLVED FIXED
Alias: None
Product: calligrawords
Classification: Unclassified
Component: general (show other bugs)
Version: Git
Platform: Other Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-10 00:04 UTC by Sven Langkamp
Modified: 2013-02-03 12:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot before (252.22 KB, image/png)
2013-01-10 00:07 UTC, Sven Langkamp
Details
Screenshot after (190.03 KB, image/png)
2013-01-10 00:07 UTC, Sven Langkamp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Langkamp 2013-01-10 00:04:19 UTC
The dockers that are docked on the right are much wider after I close a document and load it again.

Reproducible: Always

Steps to Reproduce:
1. make docker toolbar less wide
2. close the document
3. open document
Actual Results:  
Dockers are now wider

Expected Results:  
Should have the same size as before.
Comment 1 Sven Langkamp 2013-01-10 00:07:21 UTC
Created attachment 76352 [details]
Screenshot before
Comment 2 Camilla Boemann 2013-01-10 00:07:39 UTC
Probably because of the use of qtoolbox and more specifically the scrollview within.

I'm not going to fix this, as i want to implement a replacement for the modebox
Comment 3 Sven Langkamp 2013-01-10 00:07:55 UTC
Created attachment 76353 [details]
Screenshot after
Comment 4 Sven Langkamp 2013-01-10 00:20:41 UTC
It only happens when the statistics docker is open. So reopening.
Comment 5 Sven Langkamp 2013-02-03 12:42:11 UTC
Git commit dbac221139137a99c933d895487116ecc265f5db by Sven Langkamp.
Committed on 03/02/2013 at 13:40.
Pushed by langkamp into branch 'master'.

Fix width of Words statistics docker after opening a document
REVIEW:108726

M  +7    -20   words/part/dockers/KWStatisticsDocker.cpp
M  +20   -6    words/part/dockers/KWStatisticsWidget.cpp
M  +6    -2    words/part/dockers/KWStatisticsWidget.h

http://commits.kde.org/calligra/dbac221139137a99c933d895487116ecc265f5db