Bug 310485 - Give "Reset To Default" Option
Summary: Give "Reset To Default" Option
Status: RESOLVED FIXED
Alias: None
Product: homerun
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR critical
Target Milestone: ---
Assignee: Homerun bugs.
URL:
Keywords:
: 310306 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-22 09:50 UTC by swapnil bhartiya
Modified: 2013-02-21 18:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description swapnil bhartiya 2012-11-22 09:50:17 UTC
I installed Homerun to test and while playing with configuration  I removed (-) all the options that where there. 

Now when I run Homerun I get an empty Dash and hitting Config button crashes it. 

I tried to uninstall and install again but seems like the config file is saved somewhere in the system. 

Users may (and chances are will) do this mistake and lose the settings so I  suggest there should be 'reset to default' or just 'default' option so that if someone messes it up they can reset and get back the default settings.


Reproducible: Always
Comment 1 Aurelien Gateau 2012-12-12 17:30:29 UTC
Git commit 0f8402519ef0fe8de20db51f1c9d736d675be0e9 by Aurélien Gâteau.
Committed on 12/12/2012 at 18:30.
Pushed by gateau into branch 'homerun/0.1'.

Fix crash when trying to add a tab to an empty model

M  +10   -5    components/tabmodel.cpp
M  +21   -0    tests/auto/tabmodeltest.cpp
M  +1    -0    tests/auto/tabmodeltest.h

http://commits.kde.org/homerun/0f8402519ef0fe8de20db51f1c9d736d675be0e9
Comment 2 Aurelien Gateau 2012-12-12 17:32:49 UTC
*** Bug 310306 has been marked as a duplicate of this bug. ***
Comment 3 Aurelien Gateau 2013-02-21 18:02:21 UTC
Git commit 89e7c34833b6ffa2f6aae59aa6ec66114bd0f7db by Aurélien Gâteau.
Committed on 21/02/2013 at 19:01.
Pushed by gateau into branch 'master'.

Merge branch 'reset-tabs'


http://commits.kde.org/homerun/89e7c34833b6ffa2f6aae59aa6ec66114bd0f7db