Bug 310411 - Crash when selecting 'Game>Restart puzzle'
Summary: Crash when selecting 'Game>Restart puzzle'
Status: RESOLVED FIXED
Alias: None
Product: palapeli
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stefan Majewsky
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-20 15:49 UTC by Peter Hillier-Brook
Modified: 2013-12-30 12:07 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Hillier-Brook 2012-11-20 15:49:52 UTC
Application: palapeli (1.2)
KDE Platform Version: 4.9.2
Qt Version: 4.8.3
Operating System: Linux 3.5.0-18-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed: Opened palapeli and selected Game>Restart puzzle. This is repeatable behaviour.

-- Backtrace:
Application: Palapeli (palapeli), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe2b3037780 (LWP 4426))]

Thread 2 (Thread 0x7fe2a1b6a700 (LWP 4427)):
#0  0x00007fe2ac6ee754 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fe2ac6eecf9 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe2ac6eeea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe2b1725c16 in QEventDispatcherGlib::processEvents (this=0x7fe29c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fe2b16f62bf in QEventLoop::processEvents (this=this@entry=0x7fe2a1b69dd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe2b16f6548 in QEventLoop::exec (this=0x7fe2a1b69dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fe2b15f7b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fe2b16d69af in QInotifyFileSystemWatcherEngine::run (this=0x211e910) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe2b15faaec in QThreadPrivate::start (arg=0x211e910) at thread/qthread_unix.cpp:338
#9  0x00007fe2acfb5e9a in start_thread (arg=0x7fe2a1b6a700) at pthread_create.c:308
#10 0x00007fe2b0007cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe2b3037780 (LWP 4426)):
[KCrash Handler]
#6  QString (other=<error reading variable: Cannot access memory at address 0x10>, this=0x7fff1ffefa70) at /usr/include/qt4/QtCore/qstring.h:725
#7  Palapeli::Puzzle::identifier (this=0x0) at ../../../palapeli/src/file-io/puzzle.cpp:175
#8  0x000000000043ba3d in Palapeli::Scene::restartPuzzle (this=0x2107f10) at ../../../palapeli/src/engine/scene.cpp:365
#9  0x00007fe2b170cf5f in QMetaObject::activate (sender=0x22d9c30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff1ffefc00) at kernel/qobject.cpp:3547
#10 0x00007fe2b0a98a32 in QAction::triggered (this=this@entry=0x22d9c30, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#11 0x00007fe2b0a98c20 in QAction::activate (this=0x22d9c30, event=<optimized out>) at kernel/qaction.cpp:1257
#12 0x00007fe2b0ed73d3 in QMenuPrivate::activateCausedStack (this=this@entry=0x230a060, causedStack=..., action=action@entry=0x22d9c30, action_e=action_e@entry=QAction::Trigger, self=self@entry=true) at widgets/qmenu.cpp:1028
#13 0x00007fe2b0edd6b9 in QMenuPrivate::activateAction (this=0x230a060, action=0x22d9c30, action_e=QAction::Trigger, self=<optimized out>) at widgets/qmenu.cpp:1120
#14 0x00007fe2b2444090 in KMenu::mouseReleaseEvent (this=0x2313760, e=0x7fff1fff07a0) at ../../kdeui/widgets/kmenu.cpp:464
#15 0x00007fe2b0aee850 in QWidget::event (this=0x2313760, event=0x7fff1fff07a0) at kernel/qwidget.cpp:8371
#16 0x00007fe2b0ede96b in QMenu::event (this=0x2313760, e=0x7fff1fff07a0) at widgets/qmenu.cpp:2469
#17 0x00007fe2b0a9ee9c in QApplicationPrivate::notify_helper (this=this@entry=0x1f569b0, receiver=receiver@entry=0x2313760, e=e@entry=0x7fff1fff07a0) at kernel/qapplication.cpp:4562
#18 0x00007fe2b0aa3b6b in QApplication::notify (this=<optimized out>, receiver=0x2313760, e=0x7fff1fff07a0) at kernel/qapplication.cpp:4105
#19 0x00007fe2b238b1d6 in KApplication::notify (this=0x7fff1fff1410, receiver=0x2313760, event=0x7fff1fff07a0) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007fe2b16f756e in QCoreApplication::notifyInternal (this=0x7fff1fff1410, receiver=0x2313760, event=0x7fff1fff07a0) at kernel/qcoreapplication.cpp:915
#21 0x00007fe2b0a9fcd3 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#22 QApplicationPrivate::sendMouseEvent (receiver=0x2313760, event=0x7fff1fff07a0, alienWidget=0x0, nativeWidget=0x2313760, buttonDown=0x7fe2b157b308 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3173
#23 0x00007fe2b0b1d41c in QETWidget::translateMouseEvent (this=this@entry=0x2313760, event=event@entry=0x7fff1fff0f20) at kernel/qapplication_x11.cpp:4556
#24 0x00007fe2b0b1c44f in QApplication::x11ProcessEvent (this=0x7fff1fff1410, event=0x7fff1fff0f20) at kernel/qapplication_x11.cpp:3737
#25 0x00007fe2b0b43fa2 in x11EventSourceDispatch (s=0x1f57770, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#26 0x00007fe2ac6eeab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fe2ac6eede8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fe2ac6eeea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fe2b1725bf6 in QEventDispatcherGlib::processEvents (this=0x1f314b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#30 0x00007fe2b0b43c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007fe2b16f62bf in QEventLoop::processEvents (this=this@entry=0x7fff1fff12f0, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007fe2b16f6548 in QEventLoop::exec (this=0x7fff1fff12f0, flags=...) at kernel/qeventloop.cpp:204
#33 0x00007fe2b16fb708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#34 0x0000000000424882 in main (argc=1, argv=0x7fff1fff1548) at ../../../palapeli/src/main.cpp:51

Possible duplicates by query: bug 305797.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-11-20 16:37:49 UTC

*** This bug has been marked as a duplicate of bug 305797 ***
Comment 2 Ian Wadham 2013-12-24 05:27:53 UTC
I can reproduce this bug: and I do not think it is a duplicate of bug 305797, which I can not reproduce. As I am working on the Palapeli code ATM, I will try to make some time after Christmas to have a look at fixing this bug.
Comment 3 Ian Wadham 2013-12-28 23:49:42 UTC
Git commit 578eeb78cba72e162df0963e6b0f44a0c07b49a1 by Ian Wadham.
Committed on 28/12/2013 at 23:45.
Pushed by ianw into branch 'KDE/4.11'.

M  +3    -0    src/engine/scene.cpp
M  +3    -0    src/window/mainwindow.cpp

http://commits.kde.org/palapeli/578eeb78cba72e162df0963e6b0f44a0c07b49a1