Bug 310200 - Cannot add a network printer from a remote CUPS server's queue
Summary: Cannot add a network printer from a remote CUPS server's queue
Status: RESOLVED FIXED
Alias: None
Product: print-manager
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Daniel Nicoletti
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-16 11:36 UTC by Vita Humpa
Modified: 2013-01-14 22:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vita Humpa 2012-11-16 11:36:39 UTC
This is a missing functionality that was present back in system-config-printer-kde, as well as is present in system-config-printer (rh/fedora) and gnome's new control center module. 

Back in system-config-printer-kde it was possible to use a 'find' button in the IPP section that would bring in a list of available printers after typing in just the server's hostname. No need to choose drivers etc. as all would go through the remote CUPS. In fact, I am unable to add a printer even if I add the ipp:// address straight to it.

I can see and manage printers already configured elsewhere using this method. 

Reproducible: Always

Steps to Reproduce:
1. Hit 'Add printer'
2. Go to IPP section or look anywhere else

Actual Results:  
No possibilities to search for printers in some server's queue
Comment 1 Daniel Nicoletti 2013-01-14 22:13:57 UTC
Git commit 06cdd75e0d89160108978a17f757c4de806cfec2 by Daniel Nicoletti.
Committed on 14/01/2013 at 23:10.
Pushed by dantti into branch 'KDE/4.10'.

Fixed regression due to the lack of browsing queues that system-config-printer had

M  +1    -0    add-printer/CMakeLists.txt
M  +108  -15   add-printer/ChooseUri.cpp
M  +22   -0    add-printer/ChooseUri.h
M  +23   -16   add-printer/DevicesModel.cpp
M  +9    -8    add-printer/DevicesModel.h
M  +37   -2    add-printer/PageChoosePPD.cpp
M  +5    -2    add-printer/PageChoosePPD.h
M  +14   -0    add-printer/PageDestinations.cpp
M  +7    -0    add-printer/PageDestinations.h
M  +7    -1    libkcups/KCupsConnection.cpp
M  +27   -3    libkcups/KCupsRequest.cpp
M  +9    -1    libkcups/KCupsRequest.h

http://commits.kde.org/print-manager/06cdd75e0d89160108978a17f757c4de806cfec2